summaryrefslogtreecommitdiff
path: root/packaging/coreclr.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/coreclr.spec')
-rw-r--r--packaging/coreclr.spec8
1 files changed, 5 insertions, 3 deletions
diff --git a/packaging/coreclr.spec b/packaging/coreclr.spec
index 1a8596095a..05ee6d89d4 100644
--- a/packaging/coreclr.spec
+++ b/packaging/coreclr.spec
@@ -23,9 +23,10 @@ Source1000: downloaded_files.tar.gz
Source1001: %{name}.manifest
Source1002: libicu.tar.gz
Source1003: dep_libs.tar.gz
-# Gbp-Ignore-Patches: 0 1
+# Gbp-Ignore-Patches: 0 1 2
Patch0: Add-project.lock.json-files.patch
Patch1: Add-Tizen-RuntimeID-case.patch
+Patch2: Change-O3-build-in-clang3.8.patch
ExcludeArch: aarch64
@@ -112,6 +113,7 @@ cp %{SOURCE1001} .
# Gbp-Patch-Macros
%patch0 -p1
%patch1 -p1
+%patch2 -p1
cp %{SOURCE1000} ./
tar xf %{SOURCE1000}
%ifarch %{arm} %{ix86}
@@ -231,7 +233,7 @@ export PAL_DBG_CHANNELS=""
# No build native and mscorlib.
%else
# Build native only.
-./build.sh %{_barch} %{_buildtype} clang3.8 skipmscorlib skipgenerateversion skipnuget %{testopt} cmakeargs -DFEATURE_GDBJIT=TRUE
+./build.sh %{_barch} %{_buildtype} clang3.8 skipmscorlib skipgenerateversion skipnuget %{testopt} stripSymbols cmakeargs -DFEATURE_GDBJIT=TRUE
%endif
%else
%if 0%{skipnative}
@@ -239,7 +241,7 @@ export PAL_DBG_CHANNELS=""
./build.sh %{_barch} %{_buildtype} -skiprestore skipnative skipnuget %{testopt}
%else
# Build native and mscorlib.
-./build.sh %{_barch} %{_buildtype} clang3.8 skipgenerateversion -skiprestore skipnuget %{testopt} cmakeargs -DFEATURE_GDBJIT=TRUE
+./build.sh %{_barch} %{_buildtype} clang3.8 skipgenerateversion -skiprestore skipnuget %{testopt} stripSymbols cmakeargs -DFEATURE_GDBJIT=TRUE
%endif
%endif