summaryrefslogtreecommitdiff
path: root/packaging/coreclr.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/coreclr.spec')
-rw-r--r--packaging/coreclr.spec10
1 files changed, 6 insertions, 4 deletions
diff --git a/packaging/coreclr.spec b/packaging/coreclr.spec
index e8f5a0aa97..419ccbd616 100644
--- a/packaging/coreclr.spec
+++ b/packaging/coreclr.spec
@@ -22,6 +22,7 @@ URL: http://github.com/dotnet/coreclr
Source0: %{name}-%{version}.tar.gz
Source1000: downloaded_files.tar.gz
Source1001: %{name}.manifest
+Source1002: libicu.tar.gz
# Gbp-Ignore-Patches: 0 1 2
Patch0: Add-Tizen-distro.patch
Patch1: Do-not-ignore-project.lock.json.patch
@@ -103,13 +104,14 @@ cp %{SOURCE1001} .
cp %{SOURCE1000} ./
tar xf %{SOURCE1000}
%ifarch armv7l
+%setup -T -D -a 1002
patchelf --set-interpreter /emul/lib64/ld-linux-x86-64.so.2 ./Tools/dotnetcli/dotnet
-patchelf --set-rpath /emul/usr/lib64/ ./Tools/dotnetcli/dotnet
+patchelf --set-rpath /emul/usr/lib64/:%{_builddir}/%{name}-%{version}/libicu/ ./Tools/dotnetcli/dotnet
patchelf --set-interpreter /emul/lib64/ld-linux-x86-64.so.2 ./Tools/dotnetcli/shared/Microsoft.NETCore.App/1.0.0-rc3-002733/dotnet
-patchelf --set-rpath /emul/usr/lib64/ ./Tools/dotnetcli/shared/Microsoft.NETCore.App/1.0.0-rc3-002733/dotnet
-for file in $( find ./Tools -iname "*.so" )
+patchelf --set-rpath /emul/usr/lib64/:%{_builddir}/%{name}-%{version}/libicu/ ./Tools/dotnetcli/shared/Microsoft.NETCore.App/1.0.0-rc3-002733/dotnet
+for file in $( find ./Tools ./libicu -iname "*.so" -or -iname "*.so.*" )
do
- patchelf --set-rpath /emul/usr/lib64/ $file
+ patchelf --set-rpath /emul/usr/lib64/:%{_builddir}/%{name}-%{version}/libicu/ $file
done
%endif
%endif