summaryrefslogtreecommitdiff
path: root/packaging/coreclr.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/coreclr.spec')
-rw-r--r--packaging/coreclr.spec21
1 files changed, 18 insertions, 3 deletions
diff --git a/packaging/coreclr.spec b/packaging/coreclr.spec
index 5e43f26bdc..7d93198bf8 100644
--- a/packaging/coreclr.spec
+++ b/packaging/coreclr.spec
@@ -23,7 +23,7 @@ Source1000: downloaded_files.tar.gz
Source1001: %{name}.manifest
Source1002: libicu.tar.gz
Source1003: dep_libs.tar.gz
-# Gbp-Ignore-Patches: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77
+# Gbp-Ignore-Patches: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91
Patch0: 0001-Add-project.assets.json-files.patch
Patch1: 0001-ARM-Linux-Support-unaligned-struct-read-write-11290.patch
Patch2: 0002-x86-Linux-Thread-safe-UMThunkMarshInfo-RunTimeInit-1.patch
@@ -102,6 +102,20 @@ Patch74: 0029-Allocate-FileMappingImmutableData-szFileName-and-CFi.patch
Patch75: 0030-Remove-relocations-for-MethodTable-m_pParentMethodTa.patch
Patch76: 0031-Fix-build-break-with-older-VS-versions-16522.patch
Patch77: 0032-Fix-handling-of-incorrect-assemblies-on-Unix-16747.patch
+Patch78: 0001-Linux-ARM-Fix-managed-breakpoints-13316.patch
+Patch79: 0002-Merge-pull-request-13944-from-ayuckhulk-fix-arm-set-.patch
+Patch80: 0003-Fix-Linux-x86-FuncEvalHijack-stack-alignment-17143.patch
+Patch81: 0004-Fix-funclet-unwinding-on-x86-Linux-17144.patch
+Patch82: 0005-Add-environment-variable-COMPlus_EnableDiagnostics-t.patch
+Patch83: 0006-Fix-x86-Linux-ICorDebug-frames-API.patch
+Patch84: 0007-Fix-unwinding-of-funclet-with-no-epilog-on-x86-Linux.patch
+Patch85: 0008-Fix-HelperMethodFrame-UpdateRegDisplay.patch
+Patch86: 0009-Fix-regdisplay-initialization-in-case-of-WIN64EXCEPT.patch
+Patch87: 0010-Fix-CopyREGDISPLAY-for-WIN64EXCEPTIONS.patch
+Patch88: 0011-Enable-thread-abort-reraise-loop-prevention.patch
+Patch89: 0012-16-byte-Stack-Aligned-StubDispatchFixupStub.patch
+Patch90: 0013-Fix-EECodeManager-GetAmbientSP-on-x86-Linux.patch
+Patch91: 0014-Fix-OOPStackUnwinderX86-Unwind-crash-when-Eip-is-inv.patch
ExcludeArch: aarch64
@@ -282,6 +296,7 @@ cp %{SOURCE1001} .
%patch76 -p1
%patch77 -p1
+
%if 0%{skipmscorlib}
%else
cp %{SOURCE1000} ./
@@ -379,7 +394,7 @@ export CXXFLAGS+="-fstack-protector-strong"
# No build native and mscorlib.
%else
# Build native only.
-./build.sh %{_barch} %{_buildtype} clang3.8 skipmscorlib skipgenerateversion skipnuget %{testopt} cmakeargs "-DFEATURE_GDBJIT=TRUE -DFEATURE_DBGIPC=0 -DFEATURE_NI_BIND_FALLBACK=false -DCMAKE_C_COMPILER=/usr/bin/clang -DCMAKE_CXX_COMPILER=/usr/bin/clang++ -DCMAKE_SHARED_LINKER_FLAGS=-Wl,-z,relro -DCMAKE_EXE_LINKER_FLAGS=-Wl,-z,relro"
+./build.sh %{_barch} %{_buildtype} clang3.8 skipmscorlib skipgenerateversion skipnuget %{testopt} cmakeargs "-DFEATURE_GDBJIT=TRUE -DFEATURE_NI_BIND_FALLBACK=false -DCMAKE_C_COMPILER=/usr/bin/clang -DCMAKE_CXX_COMPILER=/usr/bin/clang++ -DCMAKE_SHARED_LINKER_FLAGS=-Wl,-z,relro -DCMAKE_EXE_LINKER_FLAGS=-Wl,-z,relro"
%endif
%else
%if 0%{skipnative}
@@ -387,7 +402,7 @@ export CXXFLAGS+="-fstack-protector-strong"
./build.sh %{_barch} %{_buildtype} -skiprestore skipnative skipnuget %{testopt}
%else
# Build native and mscorlib.
-./build.sh %{_barch} %{_buildtype} clang3.8 skipgenerateversion -skiprestore skipnuget %{testopt} cmakeargs "-DFEATURE_GDBJIT=TRUE -DFEATURE_DBGIPC=0 -DFEATURE_NI_BIND_FALLBACK=false -DCMAKE_C_COMPILER=/usr/bin/clang -DCMAKE_CXX_COMPILER=/usr/bin/clang++ -DCMAKE_SHARED_LINKER_FLAGS=-Wl,-z,relro -DCMAKE_EXE_LINKER_FLAGS=-Wl,-z,relro"
+./build.sh %{_barch} %{_buildtype} clang3.8 skipgenerateversion -skiprestore skipnuget %{testopt} cmakeargs "-DFEATURE_GDBJIT=TRUE -DFEATURE_NI_BIND_FALLBACK=false -DCMAKE_C_COMPILER=/usr/bin/clang -DCMAKE_CXX_COMPILER=/usr/bin/clang++ -DCMAKE_SHARED_LINKER_FLAGS=-Wl,-z,relro -DCMAKE_EXE_LINKER_FLAGS=-Wl,-z,relro"
%endif
%endif