summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 7 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8057d67a28..e59995ddcf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -588,6 +588,13 @@ if(WIN32)
add_compile_options(/Zl) # omit default library name in .OBJ
endif(WIN32)
+#------------------------------
+# Add Test Directory
+#------------------------------
+if(CLR_CMAKE_BUILD_TESTS)
+ add_subdirectory(tests)
+endif(CLR_CMAKE_BUILD_TESTS)
+
#--------------------------------
# Definition directives
# - all clr specific compile definitions should be included in this file
@@ -622,16 +629,4 @@ set(BuildToolsDir "${CLR_CMAKE_PACKAGES_DIR}/Microsoft.DotNet.BuildTools.CoreCLR
#------------------------------
add_subdirectory(src)
-#------------------------------
-# Add Test Directory
-#------------------------------
-if(CLR_CMAKE_BUILD_TESTS)
- # remove some definitions for test build
- remove_definitions(-D_SECURE_SCL=0)
- remove_definitions(-DUNICODE)
- remove_definitions(-D_UNICODE)
-
- add_subdirectory(tests)
-endif(CLR_CMAKE_BUILD_TESTS)
-
include(definitionsconsistencycheck.cmake)