summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Mitchell <mmitche@microsoft.com>2015-03-11 11:45:35 -0700
committerMatt Mitchell <mmitche@microsoft.com>2015-03-16 13:23:18 -0700
commitf8ac5bbef56de08051dace78e9334af89de15da0 (patch)
treef3408da6eb3120f9cd38cd24f74587f658680aad /tests/CMakeLists.txt
parente17f380d6308c9ef7070b2193eedacfcc60a86b1 (diff)
downloadcoreclr-f8ac5bbef56de08051dace78e9334af89de15da0.tar.gz
coreclr-f8ac5bbef56de08051dace78e9334af89de15da0.tar.bz2
coreclr-f8ac5bbef56de08051dace78e9334af89de15da0.zip
Fixes for building tests alone
This change fixes an issue where tests cannot be built alone as well as cleans up the paths. The general path cleanup was done so that the path format and variable names generally follow the main build of the coreclr repo. Some highlights are: * Don't use Cmake as a directory name for intermediates, use intermediates instead. * Disable 4820 warning (this is about padding) when building tests. Reduces noise in output significantly * Some fixes in typos and casing in the project files and build scripts
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index f2d444c436..408e029c37 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -6,6 +6,12 @@ if (WIN32)
add_definitions(-DWINDOWS=1)
endif()
+# Compile options
+
+if (WIN32)
+ add_compile_options(-wd4820)
+endif()
+
MACRO(SUBDIRLIST result curdir)
FILE(GLOB children RELATIVE ${curdir} ${curdir}/*)
SET(dirlist "")
@@ -29,3 +35,4 @@ MACRO(ADDSUBDIR_REC curdir)
ENDMACRO()
ADDSUBDIR_REC(${CMAKE_CURRENT_SOURCE_DIR})
+