summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Robinson <arobins@microsoft.com>2018-08-16 11:21:51 -0700
committerGitHub <noreply@github.com>2018-08-16 11:21:51 -0700
commitf0f42d4c0fc3cfd782b89171840e2590604392cd (patch)
treec89ed0ffe7ba540d952cefd89f267e1912aedecf /tests/CMakeLists.txt
parent72e9b8d589f114776e3f42058d721058b77133b9 (diff)
downloadcoreclr-f0f42d4c0fc3cfd782b89171840e2590604392cd.tar.gz
coreclr-f0f42d4c0fc3cfd782b89171840e2590604392cd.tar.bz2
coreclr-f0f42d4c0fc3cfd782b89171840e2590604392cd.zip
Build-test.sh handles native test assets (#19430)
* Respect Windows script argument to skip package building. * Bring build.sh logic closer to build.cmd with respect to passing CMAKE flags for building tests * Make cmake gen script find override file without using script arguments * build-test.sh can now build native test projects Remove compileoptions.cmake and push contents into configurecompiler.cmake which contains compiler configuration from repo root CMakeLists.txt
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 3 insertions, 9 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 44e9e536b4..388ce6d5d8 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,15 +1,9 @@
# Require at least version 2.8.12 of CMake
cmake_minimum_required(VERSION 2.8.12)
-if (CMAKE_CONFIGURATION_TYPES) # multi-configuration generator?
- set(CMAKE_CONFIGURATION_TYPES "Debug;Checked;Release;RelWithDebInfo" CACHE STRING "" FORCE)
-endif (CMAKE_CONFIGURATION_TYPES)
-set(CMAKE_C_FLAGS_CHECKED "")
-set(CMAKE_CXX_FLAGS_CHECKED "")
-set(CMAKE_EXE_LINKER_FLAGS_CHECKED "")
-set(CMAKE_SHARED_LINKER_FLAGS_CHECKED "")
-
-set(CLR_CMAKE_TARGET_ARCH ${CLR_CMAKE_HOST_ARCH})
+# Include global configure settings
+include(${CMAKE_CURRENT_SOURCE_DIR}/../configure.cmake)
+include(${CMAKE_CURRENT_SOURCE_DIR}/../configurecompiler.cmake)
set(INC_PLATFORM_DIR ${CMAKE_CURRENT_SOURCE_DIR}/src/Common/Platform)
if (WIN32)