summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorEugene Rozenfeld <erozen@microsoft.com>2015-12-15 17:40:43 -0800
committerEugene Rozenfeld <erozen@microsoft.com>2015-12-21 15:20:57 -0800
commit3df44ef76ffc7d3c9932eb24e9e1e1d71f02c069 (patch)
tree0510ffcdfef296301d5c9e52a663453f5780afb1 /tests/CMakeLists.txt
parentea7f6d05953cd1660b07621dac11d4d204d3bbbb (diff)
downloadcoreclr-3df44ef76ffc7d3c9932eb24e9e1e1d71f02c069.tar.gz
coreclr-3df44ef76ffc7d3c9932eb24e9e1e1d71f02c069.tar.bz2
coreclr-3df44ef76ffc7d3c9932eb24e9e1e1d71f02c069.zip
Enable checked builds of CoreCLR.
In checked builds coreclr, mscorlib, and the test are built optimized but assertion checking is on. This adds additional coverage (the jit is optimizing and assertion checking is on), speeds up testing compared to debug, and allows testing JIT stress modes. This doesn't affect CoreFX. Several tests are currently failing in checked configuration due to newly discovered bugs (JIT asserts). We didn't see these asserts in debug mode because by default JIT is in minopt mode; we didn't see these bugs in release mode because assertion checking is off. I will file the bugs once checked build changes are in.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 2021fd1add..c45f42431c 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,6 +1,14 @@
# Require at least version 2.8.12 of CMake
cmake_minimum_required(VERSION 2.8.12)
+if (CMAKE_CONFIGURATION_TYPES) # multi-configuration generator?
+ set(CMAKE_CONFIGURATION_TYPES "Debug;Checked;Release;RelWithDebInfo" CACHE STRING "" FORCE)
+endif (CMAKE_CONFIGURATION_TYPES)
+set(CMAKE_C_FLAGS_CHECKED "")
+set(CMAKE_CXX_FLAGS_CHECKED "")
+set(CMAKE_EXE_LINKER_FLAGS_CHECKED "")
+set(CMAKE_SHARED_LINKER_FLAGS_CHECKED "")
+
set(INC_PLATFORM_DIR ${CMAKE_CURRENT_SOURCE_DIR}/src/Common/Platform)
if (WIN32)
add_definitions(-DWINDOWS=1)