summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Danes <onemihaid@hotmail.com>2015-12-20 12:29:13 +0200
committerMike Danes <onemihaid@hotmail.com>2015-12-20 12:29:13 +0200
commit27714e151f35ac31f3554e370d87154c0b770861 (patch)
tree15801a1e84eb848717043557058f79653c853799 /tests/CMakeLists.txt
parentea7f6d05953cd1660b07621dac11d4d204d3bbbb (diff)
downloadcoreclr-27714e151f35ac31f3554e370d87154c0b770861.tar.gz
coreclr-27714e151f35ac31f3554e370d87154c0b770861.tar.bz2
coreclr-27714e151f35ac31f3554e370d87154c0b770861.zip
Cleanup warnings in native test projects
Most of the warnings (>10000) are generated by /Wall. It doesn't make much sense to use /Wall but since there's only a small number of warning types that cause issues I left /Wall in and disabled those particular warning types. A few other warnings were caused by actual code issues (signed/unsigned mismatch, pointer cast to int, unused variables) which I fixed.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 2021fd1add..c4d43896be 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -9,7 +9,7 @@ endif()
# Compile options
if (WIN32)
- add_compile_options(-wd4820)
+ add_compile_options(-wd4100 -wd4514 -wd4668 -wd4710 -wd4711 -wd4820)
endif()
if(CLR_CMAKE_PLATFORM_UNIX)