summaryrefslogtreecommitdiff
path: root/src/vm/wks/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Ellis <matell@microsoft.com>2016-07-12 17:58:02 -0700
committerMatt Ellis <matell@microsoft.com>2016-07-12 17:58:02 -0700
commit2de2e19645b8ca536940f739e4106d7bdfdf50a3 (patch)
treea0c5addcf046fb1c2e57c2bac867cbce6eb5f743 /src/vm/wks/CMakeLists.txt
parent0804d53c08804928e3b92e3c50b284453dab4944 (diff)
downloadcoreclr-2de2e19645b8ca536940f739e4106d7bdfdf50a3.tar.gz
coreclr-2de2e19645b8ca536940f739e4106d7bdfdf50a3.tar.bz2
coreclr-2de2e19645b8ca536940f739e4106d7bdfdf50a3.zip
Suppress Interactive Shell when running PS
On recent builds of Windows/PowerShell it seems like PS wants to write a prompt after invoking the script, which causes a problem because that puts extra gunk into the generated source file from h2inc, which causes downstream failures.
Diffstat (limited to 'src/vm/wks/CMakeLists.txt')
-rw-r--r--src/vm/wks/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/vm/wks/CMakeLists.txt b/src/vm/wks/CMakeLists.txt
index a2468caba6..0ff0ccb9a6 100644
--- a/src/vm/wks/CMakeLists.txt
+++ b/src/vm/wks/CMakeLists.txt
@@ -60,7 +60,7 @@ endif()
add_custom_command(
# The AsmConstants.inc will be built in the pre-build phase of the cee_wks build
TARGET cee_wks PRE_BUILD
- COMMAND ${POWERSHELL} -NoProfile -ExecutionPolicy Bypass \"& \"\"${VM_DIR}/h2inc.ps1\"\"\" \"\"\"${VM_DIR}/${ARCH_SOURCES_DIR}/asmconstants.h\"\"\" >"${CMAKE_CURRENT_BINARY_DIR}/AsmConstants.tmp"
+ COMMAND ${POWERSHELL} -NoProfile -ExecutionPolicy Bypass -NonInteractive \"& \"\"${VM_DIR}/h2inc.ps1\"\"\" \"\"\"${VM_DIR}/${ARCH_SOURCES_DIR}/asmconstants.h\"\"\" >"${CMAKE_CURRENT_BINARY_DIR}/AsmConstants.tmp"
COMMAND ${CMAKE_CXX_COMPILER} ${DEFINITIONS} /EP "${CMAKE_CURRENT_BINARY_DIR}/AsmConstants.tmp" >"${CMAKE_CURRENT_BINARY_DIR}/AsmConstants.inc"
)