summaryrefslogtreecommitdiff
path: root/src/vm/CMakeLists.txt
diff options
context:
space:
mode:
authorJacek Blaszczynski <biosciencenow@outlook.com>2018-09-18 20:15:38 +0200
committerJan Kotas <jkotas@microsoft.com>2018-09-18 11:15:38 -0700
commit88faa0e942bcdcaf14d327892ea5bc029c02303f (patch)
treefa944f082d1d3735a3baaf80c8c9f1729625f9a2 /src/vm/CMakeLists.txt
parent404cf2f9f22032f40edf3ab6223bb560d220d770 (diff)
downloadcoreclr-88faa0e942bcdcaf14d327892ea5bc029c02303f.tar.gz
coreclr-88faa0e942bcdcaf14d327892ea5bc029c02303f.tar.bz2
coreclr-88faa0e942bcdcaf14d327892ea5bc029c02303f.zip
Add headers to cee_wks, cee_dac vcxprojs to improve developer experience (#20011)
Diffstat (limited to 'src/vm/CMakeLists.txt')
-rw-r--r--src/vm/CMakeLists.txt383
1 files changed, 383 insertions, 0 deletions
diff --git a/src/vm/CMakeLists.txt b/src/vm/CMakeLists.txt
index e5b4d0663b..54c73cce44 100644
--- a/src/vm/CMakeLists.txt
+++ b/src/vm/CMakeLists.txt
@@ -26,6 +26,9 @@ if(FEATURE_GDBJIT)
set(VM_SOURCES_GDBJIT
gdbjit.cpp
)
+ set(VM_HEADERS_GDBJIT
+ gdbjit.h
+ )
endif(FEATURE_GDBJIT)
if(FEATURE_JIT_PITCHING)
@@ -122,16 +125,133 @@ set(VM_SOURCES_DAC_AND_WKS_COMMON
zapsig.cpp
)
+set(VM_HEADERS_DAC_AND_WKS_COMMON
+ ../inc/corjit.h
+ ../inc/corjitflags.h
+ ../inc/corjithost.h
+ appdomain.hpp
+ appdomain.inl
+ array.h
+ assembly.hpp
+ baseassemblyspec.h
+ baseassemblyspec.inl
+ binder.h
+ ceeload.h
+ ceeload.inl
+ class.h
+ class.inl
+ classhash.h
+ clsload.hpp
+ clsload.inl
+ codeman.h
+ codeman.inl
+ codeversion.h
+ comdelegate.h
+ contractimpl.h
+ crst.h
+ debugdebugger.h
+ debuginfostore.h
+ decodemd.h
+ disassembler.h
+ dllimport.h
+ domainfile.h
+ domainfile.inl
+ dynamicmethod.h
+ ecall.h
+ eedbginterfaceimpl.h
+ eedbginterfaceimpl.inl
+ eehash.h
+ eehash.inl
+ encee.h
+ excep.h
+ exstate.h
+ field.h
+ fptrstubs.h
+ frames.h
+ gctoclreventsink.h
+ gcheaputilities.h
+ generics.h
+ generics.inl
+ hash.h
+ hillclimbing.h
+ ilinstrumentation.h
+ ilstubcache.h
+ ilstubresolver.h
+ inlinetracking.h
+ instmethhash.h
+ jithost.h
+ jitinterface.h
+ loaderallocator.hpp
+ loaderallocator.inl
+ memberload.h
+ method.hpp
+ method.inl
+ methodimpl.h
+ methoditer.h
+ methodtable.h
+ methodtable.inl
+ object.h
+ object.inl
+ pefile.h
+ pefile.inl
+ peimage.h
+ peimage.inl
+ peimagelayout.h
+ peimagelayout.inl
+ perfmap.h
+ perfinfo.h
+ precode.h
+ rejit.h
+ rejit.inl
+ sigformat.h
+ siginfo.hpp
+ spinlock.h
+ stackwalk.h
+ stublink.h
+ stublink.inl
+ stubmgr.h
+ syncblk.h
+ syncblk.inl
+ threadpoolrequest.h
+ threads.h
+ threads.inl
+ threadstatics.h
+ typectxt.h
+ typedesc.h
+ typedesc.inl
+ typehandle.h
+ typehandle.inl
+ typehash.h
+ typehashingalgorithms.h
+ typestring.h
+ util.hpp
+ vars.hpp
+ versionresilienthashcode.h
+ virtualcallstub.h
+ win32threadpool.h
+ yieldprocessornormalized.h
+ zapsig.h
+)
+
set( GC_SOURCES_DAC_AND_WKS_COMMON
../gc/handletable.cpp
../gc/handletablecore.cpp
../gc/handletablescan.cpp
../gc/objecthandle.cpp)
+set( GC_HEADERS_DAC_AND_WKS_COMMON
+ ../gc/handletable.h
+ ../gc/handletable.inl
+ ../gc/handletablepriv.h
+ ../gc/objecthandle.h)
+
if(FEATURE_READYTORUN)
list(APPEND VM_SOURCES_DAC_AND_WKS_COMMON
readytoruninfo.cpp
)
+ list(APPEND VM_HEADERS_DAC_AND_WKS_COMMON
+ readytoruninfo.h
+ )
endif(FEATURE_READYTORUN)
if(FEATURE_JIT_PITCHING)
@@ -146,9 +266,17 @@ set(VM_SOURCES_DAC
threaddebugblockinginfo.cpp
)
+set(VM_HEADERS_DAC
+ ${VM_HEADERS_DAC_AND_WKS_COMMON}
+ threaddebugblockinginfo.h
+)
+
set(GC_SOURCES_DAC
${GC_SOURCES_DAC_AND_WKS_COMMON})
+set(GC_HEADERS_DAC
+ ${GC_HEADERS_DAC_AND_WKS_COMMON})
+
set(VM_SOURCES_WKS
${VM_SOURCES_DAC_AND_WKS_COMMON}
appdomainnative.cpp
@@ -261,6 +389,126 @@ set(VM_SOURCES_WKS
${VM_SOURCES_GDBJIT}
)
+set(VM_HEADERS_WKS
+ ${VM_HEADERS_DAC_AND_WKS_COMMON}
+ ../inc/jithelpers.h
+ coreclr/corebindresult.h
+ coreclr/corebindresult.inl
+ appdomainnative.hpp
+ assemblyname.hpp
+ assemblynative.hpp
+ assemblyspec.hpp
+ assemblyspecbase.h
+ cachelinealloc.h
+ callcounter.h
+ callhelpers.h
+ ceemain.h
+ clrconfignative.h
+ clrex.h
+ clrprivbinderloadfile.h
+ clrvarargs.h
+ comdatetime.h
+ comdependenthandle.h
+ comdynamic.h
+ commemoryfailpoint.h
+ commodule.h
+ compatibilityswitch.h
+ comsynchronizable.h
+ comthreadpool.h
+ comutilnative.h
+ comwaithandle.h
+ customattribute.h
+ custommarshalerinfo.h
+ dllimportcallback.h
+ eeconfig.h
+ eecontract.h
+ eemessagebox.h
+ eepolicy.h
+ eeprofinterfaces.h
+ eeprofinterfaces.inl
+ eetoprofinterfaceimpl.h
+ eetoprofinterfaceimpl.inl
+ eventpipe.h
+ eventpipeblock.h
+ eventpipebuffer.h
+ eventpipebuffermanager.h
+ eventpipeconfiguration.h
+ eventpipeevent.h
+ eventpipeeventinstance.h
+ eventpipeeventsource.h
+ eventpipefile.h
+ eventpipejsonfile.h
+ eventpipemetadatagenerator.h
+ eventpipeprovider.h
+ eventpipesession.h
+ eventstore.hpp
+ fastserializer.h
+ fcall.h
+ fieldmarshaler.h
+ finalizerthread.h
+ frameworkexceptionloader.h
+ gccover.h
+ gcenv.h
+ gcenv.ee.h
+ gcenv.os.h
+ gchelpers.h
+ hosting.h
+ ibclogger.h
+ ilmarshalers.h
+ interopconverter.h
+ interoputil.h
+ interoputil.inl
+ interpreter.h
+ interpreter.hpp
+ invokeutil.h
+ managedmdimport.hpp
+ marshalnative.h
+ mdaassistants.h
+ methodtablebuilder.h
+ mlinfo.h
+ mscorlib.h
+ multicorejit.h
+ multicorejitimpl.h
+ nativeeventsource.h
+ nativeoverlapped.h
+ objectlist.h
+ olevariant.h
+ pendingload.h
+ profattach.h
+ profattachclient.h
+ profattachserver.h
+ profdetach.h
+ profilermetadataemitvalidator.h
+ profilingenumerators.h
+ profilinghelper.h
+ profilinghelper.h
+ proftoeeinterfaceimpl.h
+ proftoeeinterfaceimpl.inl
+ qcall.h
+ reflectclasswriter.h
+ reflectioninvocation.h
+ runtimehandles.h
+ sampleprofiler.h
+ sha1.h
+ simplerwlock.hpp
+ sourceline.h
+ stackingallocator.h
+ stringliteralmap.h
+ stubcache.h
+ stubgen.h
+ stubhelpers.h
+ syncclean.hpp
+ synch.h
+ synchronizationcontextnative.h
+ testhookmgr.h
+ tieredcompilation.h
+ threaddebugblockinginfo.h
+ threadsuspend.h
+ typeparse.h
+ weakreferencenative.h
+ ${VM_HEADERS_GDBJIT}
+)
+
set(GC_SOURCES_WKS
${GC_SOURCES_DAC_AND_WKS_COMMON}
../gc/gceventstatus.cpp
@@ -276,10 +524,21 @@ set(GC_SOURCES_WKS
../gc/softwarewritewatch.cpp
../gc/handletablecache.cpp)
+set(GC_HEADERS_WKS
+ ${GC_HEADERS_DAC_AND_WKS_COMMON}
+ ../gc/gceventstatus.h
+ ../gc/gcconfig.h
+ ../gc/gcscan.h
+ ../gc/gchandletableimpl.h
+ ../gc/softwarewritewatch.h)
+
if(FEATURE_EVENT_TRACE)
list(APPEND VM_SOURCES_WKS
eventtrace.cpp
)
+ list(APPEND VM_HEADERS_WKS
+ eventtracepriv.h
+ )
endif(FEATURE_EVENT_TRACE)
if(FEATURE_STANDALONE_GC)
@@ -296,6 +555,12 @@ set(VM_SOURCES_DAC_AND_WKS_WIN32
winrttypenameconverter.cpp
)
+set(VM_HEADERS_DAC_AND_WKS_WIN32
+ clrtocomcall.h
+ rcwwalker.h
+ winrttypenameconverter.h
+)
+
list(APPEND VM_SOURCES_WKS
${VM_SOURCES_DAC_AND_WKS_WIN32}
# These should not be included for Linux
@@ -326,6 +591,35 @@ list(APPEND VM_SOURCES_WKS
winrthelpers.cpp
)
+list(APPEND VM_HEADERS_WKS
+ ${VM_HEADERS_DAC_AND_WKS_WIN32}
+ # These should not be included for Linux
+ classcompat.h
+ clrprivbinderwinrt.h
+ clrprivtypecachewinrt.h
+ comcache.h
+ comcallablewrapper.h
+ comconnectionpoints.h
+ cominterfacemarshaler.h
+ commtmemberinfomap.h
+ comtoclrcall.h
+ dispatchinfo.h
+ dispparammarshaler.h
+ dwreport.h
+ eventreporter.h
+ extensibleclassfactory.h
+ mngstdinterfaces.h
+ notifyexternals.h
+ olecontexthelpers.h
+ rcwrefcache.h
+ rtlfunctions.h
+ runtimecallablewrapper.h
+ stacksampler.h
+ stdinterfaces.h
+ stdinterfaces_internal.h
+ winrthelpers.h
+)
+
list(APPEND VM_SOURCES_DAC
${VM_SOURCES_DAC_AND_WKS_WIN32}
# These should not be included for Linux
@@ -333,6 +627,13 @@ list(APPEND VM_SOURCES_DAC
clrprivtypecachewinrt.cpp
)
+list(APPEND VM_HEADERS_DAC
+ ${VM_HEADERS_DAC_AND_WKS_WIN32}
+ # These should not be included for Linux
+ clrprivbinderwinrt.h
+ clrprivtypecachewinrt.h
+)
+
if(CLR_CMAKE_TARGET_ARCH_AMD64)
set(VM_SOURCES_WKS_ARCH_ASM
${ARCH_SOURCES_DIR}/AsmHelpers.asm
@@ -355,6 +656,10 @@ if(CLR_CMAKE_TARGET_ARCH_AMD64)
${ARCH_SOURCES_DIR}/UMThunkStub.asm
${ARCH_SOURCES_DIR}/VirtualCallStubAMD64.asm
)
+
+ set(VM_HEADERS_WKS_ARCH_ASM
+ ${ARCH_SOURCES_DIR}/asmconstants.h
+ )
elseif(CLR_CMAKE_TARGET_ARCH_I386)
set(VM_SOURCES_WKS_ARCH_ASM
${ARCH_SOURCES_DIR}/RedirectedHandledJITCase.asm
@@ -362,6 +667,10 @@ elseif(CLR_CMAKE_TARGET_ARCH_I386)
${ARCH_SOURCES_DIR}/gmsasm.asm
${ARCH_SOURCES_DIR}/jithelp.asm
)
+
+ set(VM_HEADERS_WKS_ARCH_ASM
+ ${ARCH_SOURCES_DIR}/asmconstants.h
+ )
elseif(CLR_CMAKE_TARGET_ARCH_ARM)
set(VM_SOURCES_WKS_ARCH_ASM
${ARCH_SOURCES_DIR}/asmhelpers.asm
@@ -371,6 +680,10 @@ elseif(CLR_CMAKE_TARGET_ARCH_ARM)
${ARCH_SOURCES_DIR}/patchedcode.asm
${ARCH_SOURCES_DIR}/PInvokeStubs.asm
)
+
+ set(VM_HEADERS_WKS_ARCH_ASM
+ ${ARCH_SOURCES_DIR}/asmconstants.h
+ )
elseif(CLR_CMAKE_TARGET_ARCH_ARM64)
set(VM_SOURCES_WKS_ARCH_ASM
${ARCH_SOURCES_DIR}/AsmHelpers.asm
@@ -379,6 +692,9 @@ elseif(CLR_CMAKE_TARGET_ARCH_ARM64)
${ARCH_SOURCES_DIR}/PInvokeStubs.asm
)
+ set(VM_HEADERS_WKS_ARCH_ASM
+ ${ARCH_SOURCES_DIR}/asmconstants.h
+ )
endif()
else(WIN32)
@@ -437,6 +753,14 @@ if(CLR_CMAKE_TARGET_ARCH_AMD64)
${ARCH_SOURCES_DIR}/stublinkeramd64.cpp
)
+ set(VM_HEADERS_DAC_AND_WKS_ARCH
+ ${ARCH_SOURCES_DIR}/asmconstants.h
+ ${ARCH_SOURCES_DIR}/cgencpu.h
+ ${ARCH_SOURCES_DIR}/excepcpu.h
+ ${ARCH_SOURCES_DIR}/gmscpu.h
+ ${ARCH_SOURCES_DIR}/stublinkeramd64.h
+ )
+
set(VM_SOURCES_WKS_ARCH
${ARCH_SOURCES_DIR}/jithelpersamd64.cpp
${ARCH_SOURCES_DIR}/jitinterfaceamd64.cpp
@@ -445,6 +769,10 @@ if(CLR_CMAKE_TARGET_ARCH_AMD64)
gcinfodecoder.cpp
jitinterfacegen.cpp
)
+
+ set(VM_HEADERS_WKS_ARCH
+ exceptionhandling.h
+ )
elseif(CLR_CMAKE_TARGET_ARCH_I386)
set(VM_SOURCES_DAC_AND_WKS_ARCH
gcdecode.cpp
@@ -455,12 +783,24 @@ elseif(CLR_CMAKE_TARGET_ARCH_I386)
${ARCH_SOURCES_DIR}/stublinkerx86.cpp
)
+ set(VM_HEADERS_DAC_AND_WKS_ARCH
+ exinfo.h
+ ${ARCH_SOURCES_DIR}/cgencpu.h
+ ${ARCH_SOURCES_DIR}/excepcpu.h
+ ${ARCH_SOURCES_DIR}/gmscpu.h
+ ${ARCH_SOURCES_DIR}/stublinkerx86.h
+ )
+
set(VM_SOURCES_WKS_ARCH
${ARCH_SOURCES_DIR}/jitinterfacex86.cpp
${ARCH_SOURCES_DIR}/profiler.cpp
exceptionhandling.cpp
gcinfodecoder.cpp
)
+
+ set(VM_HEADERS_WKS_ARCH
+ exceptionhandling.h
+ )
elseif(CLR_CMAKE_TARGET_ARCH_ARM)
set(VM_SOURCES_DAC_AND_WKS_ARCH
${ARCH_SOURCES_DIR}/exceparm.cpp
@@ -468,18 +808,33 @@ elseif(CLR_CMAKE_TARGET_ARCH_ARM)
${ARCH_SOURCES_DIR}/armsinglestepper.cpp
)
+ set(VM_HEADERS_DAC_AND_WKS_ARCH
+ ${ARCH_SOURCES_DIR}/asmconstants.h
+ ${ARCH_SOURCES_DIR}/excepcpu.h
+ ${ARCH_SOURCES_DIR}/virtualcallstubcpu.hpp
+ )
+
set(VM_SOURCES_WKS_ARCH
${ARCH_SOURCES_DIR}/jithelpersarm.cpp
${ARCH_SOURCES_DIR}/profiler.cpp
exceptionhandling.cpp
gcinfodecoder.cpp
)
+
+ set(VM_HEADERS_WKS_ARCH
+ exceptionhandling.h
+ )
elseif(CLR_CMAKE_TARGET_ARCH_ARM64)
set(VM_SOURCES_DAC_AND_WKS_ARCH
${ARCH_SOURCES_DIR}/stubs.cpp
exceptionhandling.cpp
gcinfodecoder.cpp
)
+
+ set(VM_HEADERS_DAC_AND_WKS_ARCH
+ ${ARCH_SOURCES_DIR}/virtualcallstubcpu.hpp
+ exceptionhandling.h
+ )
endif()
if(CLR_CMAKE_PLATFORM_UNIX)
@@ -493,26 +848,54 @@ set(VM_SOURCES_DAC_ARCH
exceptionhandling.cpp
)
+set(VM_HEADERS_DAC_ARCH
+ exceptionhandling.h
+)
+
list(APPEND VM_SOURCES_WKS
${VM_SOURCES_WKS_ARCH}
${VM_SOURCES_DAC_AND_WKS_ARCH}
)
+list(APPEND VM_HEADERS_WKS
+ ${VM_HEADERS_WKS_ARCH}
+ ${VM_HEADERS_DAC_AND_WKS_ARCH}
+)
+
list(APPEND VM_SOURCES_DAC
${VM_SOURCES_DAC_ARCH}
${VM_SOURCES_DAC_AND_WKS_ARCH}
)
+list(APPEND VM_HEADERS_DAC
+ ${VM_HEADERS_DAC_ARCH}
+ ${VM_HEADERS_DAC_AND_WKS_ARCH}
+)
+
list(APPEND VM_SOURCES_WKS
${GC_SOURCES_WKS}
)
+list(APPEND VM_HEADERS_WKS
+ ${GC_HEADERS_WKS}
+)
+
# The DAC does need GC sources in order to link correctly, even if
# it's not used.
list(APPEND VM_SOURCES_DAC
${GC_SOURCES_DAC}
)
+list(APPEND VM_HEADERS_DAC
+ ${GC_HEADERS_DAC}
+)
+
+if (WIN32)
+ list(APPEND VM_SOURCES_WKS ${VM_HEADERS_WKS})
+ list(APPEND VM_SOURCES_WKS_ARCH_ASM ${VM_HEADERS_WKS_ARCH_ASM})
+ list(APPEND VM_SOURCES_DAC ${VM_HEADERS_DAC})
+endif(WIN32)
+
convert_to_absolute_path(VM_SOURCES_WKS ${VM_SOURCES_WKS})
convert_to_absolute_path(VM_SOURCES_WKS_ARCH_ASM ${VM_SOURCES_WKS_ARCH_ASM})
convert_to_absolute_path(VM_SOURCES_DAC ${VM_SOURCES_DAC})