summaryrefslogtreecommitdiff
path: root/src/vm/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2019-05-08 00:46:51 -0700
committerGitHub <noreply@github.com>2019-05-08 00:46:51 -0700
commit794f2f89399026246562181bc999a5027fb6583d (patch)
treed87fc6ee11a0b925a678dc5500a42cbc707ea58f /src/vm/CMakeLists.txt
parent653e25ec4780cfb7132dcb55bda20dbcc9c2a027 (diff)
downloadcoreclr-794f2f89399026246562181bc999a5027fb6583d.tar.gz
coreclr-794f2f89399026246562181bc999a5027fb6583d.tar.bz2
coreclr-794f2f89399026246562181bc999a5027fb6583d.zip
Add generate crash dump command to diagnostics server (#24460)
Add the DiagnosticProtocolHelper class to deserialize and dispatch the new GenerateCoreDump command. Refactor the PAL createdump launch on unhandled exception code to used by a new PAL_GenerateCoreDump method that doesn't depend on the complus dump environment variables. Changed the "full" createdump not to include the uncommitted pages and removed the "add module metadata" workaround for SOS clrstack !UNKNOWN problem now that is fixed in SOS (crashinfo.cpp).
Diffstat (limited to 'src/vm/CMakeLists.txt')
-rw-r--r--src/vm/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vm/CMakeLists.txt b/src/vm/CMakeLists.txt
index 8fb311ed2d..76adac0362 100644
--- a/src/vm/CMakeLists.txt
+++ b/src/vm/CMakeLists.txt
@@ -58,6 +58,7 @@ set(VM_SOURCES_DAC_AND_WKS_COMMON
debughelp.cpp
debuginfostore.cpp
decodemd.cpp
+ diagnosticprotocolhelper.cpp
disassembler.cpp
dllimport.cpp
domainfile.cpp