summaryrefslogtreecommitdiff
path: root/src/utilcode/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <mathstuf@gmail.com>2015-02-04 11:53:59 -0500
committerBen Boeckel <mathstuf@gmail.com>2015-02-07 21:06:44 -0500
commitff394024a0436160855bcbd4c20856efc83647e3 (patch)
tree73d0fe8a494ccf631e6eb99d1bb6fba1d3dbda1e /src/utilcode/CMakeLists.txt
parent0fd1763e028be5ef6a4fd695a18ae19234ebdaf7 (diff)
downloadcoreclr-ff394024a0436160855bcbd4c20856efc83647e3.tar.gz
coreclr-ff394024a0436160855bcbd4c20856efc83647e3.tar.bz2
coreclr-ff394024a0436160855bcbd4c20856efc83647e3.zip
Use list(APPEND) rather than set(var ${var} ...) in CMake
This avoids a variable expansion and avoids the chances of a typo being introduced in variable names.
Diffstat (limited to 'src/utilcode/CMakeLists.txt')
-rw-r--r--src/utilcode/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/utilcode/CMakeLists.txt b/src/utilcode/CMakeLists.txt
index ea760e4f97..3d2140bd79 100644
--- a/src/utilcode/CMakeLists.txt
+++ b/src/utilcode/CMakeLists.txt
@@ -72,8 +72,7 @@ set(UTILCODE_SOURCES
# They should be moved out from here into the declaration
# of UTILCODE_SOURCES above after fixing compiler errors.
if(WIN32)
- set(UTILCODE_SOURCES
- ${UTILCODE_SOURCES}
+ list(APPEND UTILCODE_SOURCES
appxutil.cpp
dlwrap.cpp
downlevel.cpp