summaryrefslogtreecommitdiff
path: root/src/utilcode/CMakeLists.txt
diff options
context:
space:
mode:
authorJeremy Koritzinsky <jekoritz@microsoft.com>2019-05-10 16:24:42 -0700
committerGitHub <noreply@github.com>2019-05-10 16:24:42 -0700
commite985b20260631c98a09f08cb67e93d690a6ffd0b (patch)
treef78350febda1071e413382c879726f111bd62c36 /src/utilcode/CMakeLists.txt
parent0dd7c86c8573f257cfd3b4b6374b7415fd3a9131 (diff)
downloadcoreclr-e985b20260631c98a09f08cb67e93d690a6ffd0b.tar.gz
coreclr-e985b20260631c98a09f08cb67e93d690a6ffd0b.tar.bz2
coreclr-e985b20260631c98a09f08cb67e93d690a6ffd0b.zip
Move EventProvider native layout to be driven by CMake configure (#24478)
* Generate eventpipe implementation as part of CMake configure. * Generate Etw provider as part of CMake configure. * First pass porting over lttng provider to cmake. * Fix up CMake Lttng provider generation. * Move Lttng provider into CMake tree. * Move dummy event provider to CMake * Move genEventing into the CMake tree. * Remove extraneous logging and unused python locator. * Clean up build.sh * Clean up genEventingTests.py * Add dependencies to enable more incremental builds (providers not fully incremental). * Convert to custom command and targets instead of at configure time. * Get each eventing target to incrementally build. * Fix incremental builds * Add missing dependencies on eventing headers. * PR Feedback. Mark all generated files as generated * Clean up eventprovider test CMakeLists
Diffstat (limited to 'src/utilcode/CMakeLists.txt')
-rw-r--r--src/utilcode/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/utilcode/CMakeLists.txt b/src/utilcode/CMakeLists.txt
index fa9abb73c8..4e5f73faf1 100644
--- a/src/utilcode/CMakeLists.txt
+++ b/src/utilcode/CMakeLists.txt
@@ -101,6 +101,8 @@ set(UTILCODE_STATICNOHOST_SOURCES
hostimpl.cpp
)
+set (UTILCODE_DEPENDENCIES eventing_headers)
+
convert_to_absolute_path(UTILCODE_SOURCES ${UTILCODE_SOURCES})
convert_to_absolute_path(UTILCODE_DAC_SOURCES ${UTILCODE_DAC_SOURCES})
convert_to_absolute_path(UTILCODE_CROSSGEN_SOURCES ${UTILCODE_CROSSGEN_SOURCES})