summaryrefslogtreecommitdiff
path: root/src/utilcode/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2016-12-18 14:48:36 -0800
committerGitHub <noreply@github.com>2016-12-18 14:48:36 -0800
commite50b22b4f07b452b3ce7261fb543a43aa8f70b88 (patch)
treea3910ccba568b59c4f60cdda7ac7cd9f8357afc9 /src/utilcode/CMakeLists.txt
parent4497b25d1107846e0ac8d09fa13e40173528fe9e (diff)
downloadcoreclr-e50b22b4f07b452b3ce7261fb543a43aa8f70b88.tar.gz
coreclr-e50b22b4f07b452b3ce7261fb543a43aa8f70b88.tar.bz2
coreclr-e50b22b4f07b452b3ce7261fb543a43aa8f70b88.zip
Remove Read/WriteProcessMemory from PAL. (#8655)
Ifdef more unused code that uses ReadProcessMemory. Move the current memory probing in the transport to PAL_ProbeMemory. Add PAL_ProbeMemory to dac PAL exports. PAL_ProbeMemory may be changed to use write/read on a pipe to validate the memory as soon as we make it perform as well as the current code. Remove ReadProcessMemory tests and add PAL_ProbeMemory pal tests.
Diffstat (limited to 'src/utilcode/CMakeLists.txt')
-rw-r--r--src/utilcode/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/utilcode/CMakeLists.txt b/src/utilcode/CMakeLists.txt
index 9d35a7e641..7c396732a1 100644
--- a/src/utilcode/CMakeLists.txt
+++ b/src/utilcode/CMakeLists.txt
@@ -41,7 +41,6 @@ set(UTILCODE_COMMON_SOURCES
outstring.cpp
ilformatter.cpp
opinfo.cpp
- dacutil.cpp
sortversioning.cpp
corimage.cpp
format1.cpp
@@ -71,6 +70,7 @@ set(UTILCODE_COMMON_SOURCES
if(WIN32)
list(APPEND UTILCODE_COMMON_SOURCES
appxutil.cpp
+ dacutil.cpp
dlwrap.cpp
downlevel.cpp
loadrc.cpp