summaryrefslogtreecommitdiff
path: root/src/palrt/CMakeLists.txt
diff options
context:
space:
mode:
authordotnet-bot <dotnet-bot@microsoft.com>2015-01-30 14:14:42 -0800
committerdotnet-bot <dotnet-bot@microsoft.com>2015-01-30 14:14:42 -0800
commitef1e2ab328087c61a6878c1e84f4fc5d710aebce (patch)
treedee1bbb89e9d722e16b0d1485e3cdd1b6c8e2cfa /src/palrt/CMakeLists.txt
downloadcoreclr-ef1e2ab328087c61a6878c1e84f4fc5d710aebce.tar.gz
coreclr-ef1e2ab328087c61a6878c1e84f4fc5d710aebce.tar.bz2
coreclr-ef1e2ab328087c61a6878c1e84f4fc5d710aebce.zip
Initial commit to populate CoreCLR repo
[tfs-changeset: 1407945]
Diffstat (limited to 'src/palrt/CMakeLists.txt')
-rw-r--r--src/palrt/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/palrt/CMakeLists.txt b/src/palrt/CMakeLists.txt
new file mode 100644
index 0000000000..231e95960f
--- /dev/null
+++ b/src/palrt/CMakeLists.txt
@@ -0,0 +1,23 @@
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+add_definitions(-DNO_CRT)
+
+set(PALRT_SOURCES
+ bstr.cpp
+ coguid.cpp
+ comem.cpp
+ decarith.cpp
+ decconv.cpp
+ guid.cpp
+ memorystream.cpp
+ path.cpp
+ urlpars.cpp
+)
+
+add_compile_options(-fPIC)
+
+add_library(palrt
+ STATIC
+ ${PALRT_SOURCES}
+)