summaryrefslogtreecommitdiff
path: root/src/pal/tests/palsuite/file_io/FindClose/test1/CMakeLists.txt
diff options
context:
space:
mode:
authorkchoi <code.kchoi@gmail.com>2016-09-07 14:12:22 -0700
committerJan Vorlicek <janvorli@microsoft.com>2016-09-07 23:12:22 +0200
commit4149bd2070e0a8beec6dedb238e6fd832a39611b (patch)
tree7aa9401597ad87d4d1d902643439af1614458b99 /src/pal/tests/palsuite/file_io/FindClose/test1/CMakeLists.txt
parent09133905fce3b541702044b6d2bbe942a6b40155 (diff)
downloadcoreclr-4149bd2070e0a8beec6dedb238e6fd832a39611b.tar.gz
coreclr-4149bd2070e0a8beec6dedb238e6fd832a39611b.tar.bz2
coreclr-4149bd2070e0a8beec6dedb238e6fd832a39611b.zip
Fix strict aliasing violation from conditional typedef of wchar_t by building entire project as C++ for Unix (#6801)
Enable building CoreCLR as C++ project on Unix This series of patches fixes the strict aliasing violation from the conditional typedef of wchar_t in src/pal/inc/pal_char16.h:40 * rename c files to cpp * modify all cmake files to change .c files to .cpp * apply c++ linkage to templates
Diffstat (limited to 'src/pal/tests/palsuite/file_io/FindClose/test1/CMakeLists.txt')
-rw-r--r--src/pal/tests/palsuite/file_io/FindClose/test1/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/pal/tests/palsuite/file_io/FindClose/test1/CMakeLists.txt b/src/pal/tests/palsuite/file_io/FindClose/test1/CMakeLists.txt
index 732c9f58d3..d97c69e6ee 100644
--- a/src/pal/tests/palsuite/file_io/FindClose/test1/CMakeLists.txt
+++ b/src/pal/tests/palsuite/file_io/FindClose/test1/CMakeLists.txt
@@ -3,7 +3,7 @@ cmake_minimum_required(VERSION 2.8.12.2)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(SOURCES
- FindClose.c
+ FindClose.cpp
)
add_executable(paltest_findclose_test1