summaryrefslogtreecommitdiff
path: root/src/pal/tests/palsuite/c_runtime/fabsf/test1/CMakeLists.txt
diff options
context:
space:
mode:
authorTanner Gooding <tannergooding@users.noreply.github.com>2016-06-01 18:17:24 -0700
committerJan Vorlicek <janvorli@microsoft.com>2016-06-02 03:17:24 +0200
commit08786f20e89eb5f518d8d25f3e7f886f69d994ea (patch)
tree7a1ff4252b23de1b2a729a933c10fc8c349b9025 /src/pal/tests/palsuite/c_runtime/fabsf/test1/CMakeLists.txt
parent5b97541ab67310b7831c4f5c13be7978c0b024cd (diff)
downloadcoreclr-08786f20e89eb5f518d8d25f3e7f886f69d994ea.tar.gz
coreclr-08786f20e89eb5f518d8d25f3e7f886f69d994ea.tar.bz2
coreclr-08786f20e89eb5f518d8d25f3e7f886f69d994ea.zip
Improvements to System.Math InternalCall code. (#4847)
* Adding some basic System.Math performance tests. * Renaming 'floatnative' to 'floatdouble'. * Removing outdated workarounds in the floatdouble interop code. * Renaming 'finite.cpp' to 'math.cpp' * Updating the double-precision math tests. * Updating PAL_EPSILON to be more precise.
Diffstat (limited to 'src/pal/tests/palsuite/c_runtime/fabsf/test1/CMakeLists.txt')
-rw-r--r--src/pal/tests/palsuite/c_runtime/fabsf/test1/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/pal/tests/palsuite/c_runtime/fabsf/test1/CMakeLists.txt b/src/pal/tests/palsuite/c_runtime/fabsf/test1/CMakeLists.txt
new file mode 100644
index 0000000000..06512ebd7c
--- /dev/null
+++ b/src/pal/tests/palsuite/c_runtime/fabsf/test1/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 2.8.12.2)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(SOURCES
+ test1.c
+)
+
+add_executable(paltest_fabsf_test1
+ ${SOURCES}
+)
+
+add_dependencies(paltest_fabsf_test1 coreclrpal)
+
+target_link_libraries(paltest_fabsf_test1
+ pthread
+ m
+ coreclrpal
+)