summaryrefslogtreecommitdiff
path: root/src/pal/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2017-08-15 17:33:04 -0700
committerGitHub <noreply@github.com>2017-08-15 17:33:04 -0700
commit52e949043ae6d6fd8d643232f2794e15a564a6a5 (patch)
tree6bbc3b0b78efb2e0c323c67bc29267d149898e5c /src/pal/src/CMakeLists.txt
parent5944aa55a541b144349a5c0ba0aecccfde9b5646 (diff)
downloadcoreclr-52e949043ae6d6fd8d643232f2794e15a564a6a5.tar.gz
coreclr-52e949043ae6d6fd8d643232f2794e15a564a6a5.tar.bz2
coreclr-52e949043ae6d6fd8d643232f2794e15a564a6a5.zip
Implement out of context stack unwinder (#13302)
Implement out of context stack unwinder Decode the eh frame info found in the in-memory module image and pass it back to the remote libunwind8 to do the unwind. Added remote-unwind.cpp for all the out of context unwind code. Added an all managed threads option -all the "clrstack" (sos ClrStack). The IDebugDataTarget4 feature needs to be enabled for OS X. Add libunwind license notice to third party notices file.
Diffstat (limited to 'src/pal/src/CMakeLists.txt')
-rw-r--r--src/pal/src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/pal/src/CMakeLists.txt b/src/pal/src/CMakeLists.txt
index b8a9fe9e46..578b1169bb 100644
--- a/src/pal/src/CMakeLists.txt
+++ b/src/pal/src/CMakeLists.txt
@@ -147,6 +147,7 @@ set(SOURCES
debug/debug.cpp
exception/seh.cpp
exception/signal.cpp
+ exception/remote-unwind.cpp
file/directory.cpp
file/disk.cpp
file/file.cpp