summaryrefslogtreecommitdiff
path: root/src/pal/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Ellis <matell@microsoft.com>2015-04-14 18:56:24 -0700
committerMatt Ellis <matell@microsoft.com>2015-04-14 18:56:24 -0700
commitcc20fca9ad308def589d7b08eb1408f23f8b9a35 (patch)
tree651f014fc390de96cf6b71fd694295b8a9c74fd8 /src/pal/src/CMakeLists.txt
parentabf43b7c3674db5547c4ab65297939d48643c831 (diff)
downloadcoreclr-cc20fca9ad308def589d7b08eb1408f23f8b9a35.tar.gz
coreclr-cc20fca9ad308def589d7b08eb1408f23f8b9a35.tar.bz2
coreclr-cc20fca9ad308def589d7b08eb1408f23f8b9a35.zip
Rename "CoreClrPal" to "coreclrpal"
Simply change the case of the library the PAL lives in so that is all lowercase.
Diffstat (limited to 'src/pal/src/CMakeLists.txt')
-rw-r--r--src/pal/src/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/pal/src/CMakeLists.txt b/src/pal/src/CMakeLists.txt
index fd2c4ad093..26f988d1cf 100644
--- a/src/pal/src/CMakeLists.txt
+++ b/src/pal/src/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 2.8.12.2)
include(configure.cmake)
-project(CoreClrPal)
+project(coreclrpal)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -149,14 +149,14 @@ set(SOURCES
thread/tls.cpp
)
-add_library(CoreClrPal
+add_library(coreclrpal
SHARED
${SOURCES}
${PLATFORM_SOURCES}
)
if(CMAKE_SYSTEM_NAME STREQUAL Linux)
- target_link_libraries(CoreClrPal
+ target_link_libraries(coreclrpal
pthread
rt
dl
@@ -169,7 +169,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL Darwin)
find_library(CORESERVICES CoreServices)
find_library(SECURITY Security)
find_library(SYSTEM System)
- target_link_libraries(CoreClrPal
+ target_link_libraries(coreclrpal
${COREFOUNDATION}
${CORESERVICES}
${SECURITY}
@@ -179,4 +179,4 @@ endif(CMAKE_SYSTEM_NAME STREQUAL Darwin)
add_subdirectory(examples)
-install(TARGETS CoreClrPal DESTINATION .) \ No newline at end of file
+install(TARGETS coreclrpal DESTINATION .) \ No newline at end of file