summaryrefslogtreecommitdiff
path: root/src/pal/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTomas Weinfurt <tweinfurt@yahoo.com>2018-05-21 17:38:50 -0700
committerGitHub <noreply@github.com>2018-05-21 17:38:50 -0700
commit49f6249abc44269b437064e850ad22eb9f74a446 (patch)
tree43ead3d24e68eef9b9fdf5360fb94fddcd4df017 /src/pal/src/CMakeLists.txt
parent3910feed29faffb67a0cacf9470461219539e632 (diff)
downloadcoreclr-49f6249abc44269b437064e850ad22eb9f74a446.tar.gz
coreclr-49f6249abc44269b437064e850ad22eb9f74a446.tar.bz2
coreclr-49f6249abc44269b437064e850ad22eb9f74a446.zip
small fixes to build CoreCLR on FreeBSD again (#18072)
* small fixes to build CoreCLR on FreeBSD again * feedback from review * update genLttngProvider.py as jan suggested * remove extra comment * add missing extra space
Diffstat (limited to 'src/pal/src/CMakeLists.txt')
-rw-r--r--src/pal/src/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/pal/src/CMakeLists.txt b/src/pal/src/CMakeLists.txt
index dbff63dc00..130e06ed4b 100644
--- a/src/pal/src/CMakeLists.txt
+++ b/src/pal/src/CMakeLists.txt
@@ -1,9 +1,9 @@
cmake_minimum_required(VERSION 2.8.12.2)
-if(CMAKE_SYSTEM_NAME STREQUAL Darwin)
- # On OSX, we use the libunwind that's part of the OS
+if(CMAKE_SYSTEM_NAME STREQUAL Darwin OR CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
+ # On OSX and *BSD, we use the libunwind that's part of the OS
set(CLR_CMAKE_USE_SYSTEM_LIBUNWIND 1)
-endif(CMAKE_SYSTEM_NAME STREQUAL Darwin)
+endif(CMAKE_SYSTEM_NAME STREQUAL Darwin OR CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
include_directories(SYSTEM /usr/local/include)