summaryrefslogtreecommitdiff
path: root/src/pal/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Kotas <jkotas@microsoft.com>2016-01-31 23:42:27 -0800
committerJan Kotas <jkotas@microsoft.com>2016-01-31 23:42:27 -0800
commit2dd9b89a6dc84795a0f9e2dc93ea6a824ae552e9 (patch)
tree26646a7624be759f8b36e251c599ddffd74b83ac /src/pal/src/CMakeLists.txt
parent1765a84c03a37c9bdb7541cb7db49adad5dae6db (diff)
downloadcoreclr-2dd9b89a6dc84795a0f9e2dc93ea6a824ae552e9.tar.gz
coreclr-2dd9b89a6dc84795a0f9e2dc93ea6a824ae552e9.tar.bz2
coreclr-2dd9b89a6dc84795a0f9e2dc93ea6a824ae552e9.zip
Stop defining WIN32 in Unix builds
WIN32 was defined for 32-bit Unix builds in number of places which is incorrect. It caused build break in lldb header since they use WIN32 define for Windows-specific code.
Diffstat (limited to 'src/pal/src/CMakeLists.txt')
-rw-r--r--src/pal/src/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/pal/src/CMakeLists.txt b/src/pal/src/CMakeLists.txt
index f527922e7b..586a27d648 100644
--- a/src/pal/src/CMakeLists.txt
+++ b/src/pal/src/CMakeLists.txt
@@ -60,7 +60,6 @@ if(PAL_CMAKE_PLATFORM_ARCH_AMD64)
add_definitions(-D_WIN64=1)
elseif(PAL_CMAKE_PLATFORM_ARCH_ARM)
add_definitions(-DBIT32=1)
- add_definitions(-D_WIN32=1)
elseif(PAL_CMAKE_PLATFORM_ARCH_ARM64)
add_definitions(-DBIT64=1)
add_definitions(-D_WIN64=1)