summaryrefslogtreecommitdiff
path: root/src/pal/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKoundinya Veluri <kouvel@microsoft.com>2015-10-20 10:37:01 -0700
committerKoundinya Veluri <kouvel@microsoft.com>2015-10-21 21:34:12 -0700
commit194d5a41455bda3f348524a1b54f59b5e0c19f0c (patch)
tree25680816288e2353704fa4bc75fa738f025f91dc /src/pal/src/CMakeLists.txt
parent57b13a94fbcdd0b429aa56d7e4faf65aeec7949a (diff)
downloadcoreclr-194d5a41455bda3f348524a1b54f59b5e0c19f0c.tar.gz
coreclr-194d5a41455bda3f348524a1b54f59b5e0c19f0c.tar.bz2
coreclr-194d5a41455bda3f348524a1b54f59b5e0c19f0c.zip
Move some functions to allow them to be inlined with clang
For the moment, GetThread, _rotl/_rotr, Interlocked..., and similar functions were moved to allow inlining them with clang. The plan is to eventually enable link-time optimization (LTO) to cover inlining across translation units. Renamed some code files in PAL tests to compile as C++ to use the C++ inline semantics.
Diffstat (limited to 'src/pal/src/CMakeLists.txt')
-rw-r--r--src/pal/src/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/pal/src/CMakeLists.txt b/src/pal/src/CMakeLists.txt
index f1a254687d..03b3ea694b 100644
--- a/src/pal/src/CMakeLists.txt
+++ b/src/pal/src/CMakeLists.txt
@@ -135,7 +135,6 @@ set(SOURCES
misc/error.cpp
misc/errorstrings.cpp
misc/fmtmessage.cpp
- misc/interlock.cpp
misc/miscpalapi.cpp
misc/msgbox.cpp
misc/strutil.cpp