summaryrefslogtreecommitdiff
path: root/src/pal/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSergey Ignatov <sergign60@mail.ru>2018-06-08 19:50:47 +0300
committer이형주/Tizen Platform Lab(SR)/Staff Engineer/삼성전자 <leee.lee@samsung.com>2018-07-06 09:25:21 +0900
commita6695d168396847df8d006a8743c84e5141824af (patch)
treef207199f438c0edf16f238514ca2816b00d68b66 /src/pal/src/CMakeLists.txt
parent05c92c50534264591900022031ec8ae5fa8f4484 (diff)
downloadcoreclr-a6695d168396847df8d006a8743c84e5141824af.tar.gz
coreclr-a6695d168396847df8d006a8743c84e5141824af.tar.bz2
coreclr-a6695d168396847df8d006a8743c84e5141824af.zip
Launching the Memory Profiler on x86 emulator may lead to crash in coreclr (xmm bug)
Diffstat (limited to 'src/pal/src/CMakeLists.txt')
-rw-r--r--src/pal/src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/pal/src/CMakeLists.txt b/src/pal/src/CMakeLists.txt
index dbff63dc00..8670972406 100644
--- a/src/pal/src/CMakeLists.txt
+++ b/src/pal/src/CMakeLists.txt
@@ -107,6 +107,8 @@ elseif(PAL_CMAKE_PLATFORM_ARCH_ARM64)
elseif(PAL_CMAKE_PLATFORM_ARCH_I386)
add_definitions(-DBIT32=1)
set(PAL_ARCH_SOURCES_DIR i386)
+ # Workaround to avoid generating sse insts for profiler
+ add_compile_options(-mno-sse -mno-avx)
endif()
if(PAL_CMAKE_PLATFORM_ARCH_AMD64 AND CMAKE_SYSTEM_NAME STREQUAL Linux AND NOT CLR_CMAKE_PLATFORM_ALPINE_LINUX)