summaryrefslogtreecommitdiff
path: root/src/md/enc/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Vorlicek <janvorli@microsoft.com>2019-08-23 17:03:01 +0200
committer이형주/Common Platform Lab(SR)/Staff Engineer/삼성전자 <leee.lee@samsung.com>2020-04-16 07:35:55 +0900
commitf3df95bc38d98acadd86a054f05b3a00ad5efd95 (patch)
treeea5f43cbb651838353342e8c704f5b991ddbdb83 /src/md/enc/CMakeLists.txt
parentfb8e002e7b146a4ce5fad76a4f5fc3a6e8bcb57b (diff)
downloadcoreclr-submit/tizen_5.5/20200415.223817.tar.gz
coreclr-submit/tizen_5.5/20200415.223817.tar.bz2
coreclr-submit/tizen_5.5/20200415.223817.zip
* Fix PIE options We were missing passing the -pie linker option. That means that while we were compiling our code as position independent, the executables (not shared libraries) were not marked as position independent and ASLR was not applied to them. They were always loaded to fixed addresses. This change adds the missing -pie option and also replaces all the individual settings of -fPIE / -fPIC on the targets we build by a centralized setting of CMAKE_POSITION_INDEPENDENT_CODE variable that causes cmake to add the appropriate compiler options everywhere. * Fix native parts of coreclr tests build The native parts of the tests are not built using the root CMakeLists.txt so I am moving enabling the position independent code to configurecompiler.cmake Change-Id: Ieafff8984ec23e5fdb00fb0c2fb017e53afbce88
Diffstat (limited to 'src/md/enc/CMakeLists.txt')
-rw-r--r--src/md/enc/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/md/enc/CMakeLists.txt b/src/md/enc/CMakeLists.txt
index 32d640a09a..2f1398d6f1 100644
--- a/src/md/enc/CMakeLists.txt
+++ b/src/md/enc/CMakeLists.txt
@@ -44,10 +44,6 @@ endif(WIN32)
convert_to_absolute_path(MDRUNTIMERW_HEADERS ${MDRUNTIMERW_HEADERS})
convert_to_absolute_path(MDRUNTIMERW_SOURCES ${MDRUNTIMERW_SOURCES})
-if(CLR_CMAKE_PLATFORM_UNIX)
- add_compile_options(-fPIC)
-endif(CLR_CMAKE_PLATFORM_UNIX)
-
add_subdirectory(dac)
add_subdirectory(wks)
add_subdirectory(dbi)