summaryrefslogtreecommitdiff
path: root/src/jit/standalone/CMakeLists.txt
diff options
context:
space:
mode:
authorBruce Forstall <brucefo@microsoft.com>2016-02-26 17:40:23 -0800
committerBruce Forstall <brucefo@microsoft.com>2016-02-26 19:24:31 -0800
commitdeb42acb17313457bd9eb7b3c50c3aca06024202 (patch)
tree27f30f1d2562f12e8a73df0e9c00015f17b6ceb5 /src/jit/standalone/CMakeLists.txt
parent894d162e62a6028a26f6bd129a299c7694b1bf42 (diff)
downloadcoreclr-deb42acb17313457bd9eb7b3c50c3aca06024202.tar.gz
coreclr-deb42acb17313457bd9eb7b3c50c3aca06024202.tar.bz2
coreclr-deb42acb17313457bd9eb7b3c50c3aca06024202.zip
Add linker magic to non-Windows standalone RyuJIT build to make PAL work better when dynamically loading it.
Diffstat (limited to 'src/jit/standalone/CMakeLists.txt')
-rw-r--r--src/jit/standalone/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/jit/standalone/CMakeLists.txt b/src/jit/standalone/CMakeLists.txt
index b0b2a02c83..ba987b409b 100644
--- a/src/jit/standalone/CMakeLists.txt
+++ b/src/jit/standalone/CMakeLists.txt
@@ -4,6 +4,11 @@ add_definitions(-DSELF_NO_HOST)
add_definitions(-DFEATURE_READYTORUN_COMPILER)
remove_definitions(-DFEATURE_MERGE_JIT_AND_ENGINE)
+if(CLR_CMAKE_PLATFORM_LINUX OR CLR_CMAKE_PLATFORM_NETBSD)
+ # This is required to force using our own PAL, not one that we are loaded with.
+ set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Xlinker -Bsymbolic -Bsymbolic-functions")
+endif(CLR_CMAKE_PLATFORM_LINUX OR CLR_CMAKE_PLATFORM_NETBSD)
+
add_library_clr(ryujit
SHARED
${SHARED_LIB_SOURCES}