summaryrefslogtreecommitdiff
path: root/src/jit/standalone/CMakeLists.txt
diff options
context:
space:
mode:
authorBruce Forstall <brucefo@microsoft.com>2017-11-20 17:18:01 -0800
committerBruce Forstall <brucefo@microsoft.com>2017-12-12 17:24:20 -0800
commite7660e3226527166352aa7999ae1ed853a9c4868 (patch)
treea7393ab4b2ffa1d3d58841322f74c56963b78275 /src/jit/standalone/CMakeLists.txt
parent802423db2359ce9c579bdca55c3cac5b21f7aca9 (diff)
downloadcoreclr-e7660e3226527166352aa7999ae1ed853a9c4868.tar.gz
coreclr-e7660e3226527166352aa7999ae1ed853a9c4868.tar.bz2
coreclr-e7660e3226527166352aa7999ae1ed853a9c4868.zip
Make RyuJIT/arm32 the default arm32 JIT
RyuJIT/arm32 JIT is now named clrjit.dll (was named protojit.dll). arm32 LEGACY_BACKEND JIT is now named legacyjit.dll (was named clrjit.dll). Ubuntu and Tizen testing now use RyuJIT/arm32. Tests failing for legacy backend are now excluded with `LEGACYJIT_JITSTRESS_FAIL`, `LEGACYJIT_GCSTRESS_FAIL`, and `LEGACYJIT_FAIL`.
Diffstat (limited to 'src/jit/standalone/CMakeLists.txt')
-rw-r--r--src/jit/standalone/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/jit/standalone/CMakeLists.txt b/src/jit/standalone/CMakeLists.txt
index 3111b03595..5f32d49c4f 100644
--- a/src/jit/standalone/CMakeLists.txt
+++ b/src/jit/standalone/CMakeLists.txt
@@ -8,10 +8,6 @@ if(FEATURE_READYTORUN)
add_definitions(-DFEATURE_READYTORUN_COMPILER)
endif(FEATURE_READYTORUN)
-if(CLR_CMAKE_TARGET_ARCH_ARM)
- add_definitions(-DLEGACY_BACKEND)
-endif()
-
if(WIN32)
add_definitions(-DFX_VER_INTERNALNAME_STR=clrjit.dll)
endif(WIN32)