summaryrefslogtreecommitdiff
path: root/src/jit/standalone/CMakeLists.txt
diff options
context:
space:
mode:
authorPat Gavlin <pagavlin@microsoft.com>2016-05-24 16:00:37 -0700
committerPat Gavlin <pagavlin@microsoft.com>2016-05-25 12:47:06 -0700
commit3ea0ad01345fccfbb7eb07da64f91cddb150b82c (patch)
tree68f9c0d22e30c708c4f99995be61bb5a48091fa1 /src/jit/standalone/CMakeLists.txt
parentbdd7edfa55ea2bdd922f4a94609fa15d674bed73 (diff)
downloadcoreclr-3ea0ad01345fccfbb7eb07da64f91cddb150b82c.tar.gz
coreclr-3ea0ad01345fccfbb7eb07da64f91cddb150b82c.tar.bz2
coreclr-3ea0ad01345fccfbb7eb07da64f91cddb150b82c.zip
Limit the exports of libclrjit.{so,dylib}.
Properly set the necessary linker options to limit libclrjit's exports on *nix platforms. This change also includes some minor cleanup to the JIT's various CMake list files.
Diffstat (limited to 'src/jit/standalone/CMakeLists.txt')
-rw-r--r--src/jit/standalone/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/jit/standalone/CMakeLists.txt b/src/jit/standalone/CMakeLists.txt
index 4e70b9ef74..b4efc30a8e 100644
--- a/src/jit/standalone/CMakeLists.txt
+++ b/src/jit/standalone/CMakeLists.txt
@@ -8,16 +8,16 @@ if(CLR_CMAKE_TARGET_ARCH_I386 OR CLR_CMAKE_TARGET_ARCH_ARM)
add_definitions(-DLEGACY_BACKEND)
endif()
-if(CLR_CMAKE_PLATFORM_LINUX OR CLR_CMAKE_PLATFORM_NETBSD)
- # This is required to force using our own PAL, not one that we are loaded with.
- set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Xlinker -Bsymbolic -Bsymbolic-functions")
-endif(CLR_CMAKE_PLATFORM_LINUX OR CLR_CMAKE_PLATFORM_NETBSD)
-
add_library_clr(${JIT_BASE_NAME}
SHARED
${SHARED_LIB_SOURCES}
)
+add_dependencies(${JIT_BASE_NAME} jit_exports)
+
+set_property(TARGET ${JIT_BASE_NAME} APPEND_STRING PROPERTY LINK_FLAGS ${JIT_EXPORTS_LINKER_OPTION})
+set_property(TARGET ${JIT_BASE_NAME} APPEND_STRING PROPERTY LINK_DEPENDS ${JIT_EXPORTS_FILE})
+
set(RYUJIT_LINK_LIBRARIES
utilcodestaticnohost
gcinfo