summaryrefslogtreecommitdiff
path: root/src/jit/CMakeLists.txt
diff options
context:
space:
mode:
authorPat Gavlin <pagavlin@microsoft.com>2017-03-10 17:11:24 -0800
committerPat Gavlin <pagavlin@microsoft.com>2017-04-05 07:22:03 -0700
commite62151a88f71edcaa336f4265b4fc534d6f56940 (patch)
tree24ce634cfc7d5e43fa42ba0b2dedd4a213e6820d /src/jit/CMakeLists.txt
parente93e79b3d012bc068c84ee5f65f8e755020d8a9c (diff)
downloadcoreclr-e62151a88f71edcaa336f4265b4fc534d6f56940.tar.gz
coreclr-e62151a88f71edcaa336f4265b4fc534d6f56940.tar.bz2
coreclr-e62151a88f71edcaa336f4265b4fc534d6f56940.zip
Only build compatjit.dll when building JIT32.
In order to avoid confusion, do not build and package compatjit.dll unless we are building JIT32. Fixes #10106.
Diffstat (limited to 'src/jit/CMakeLists.txt')
-rw-r--r--src/jit/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/jit/CMakeLists.txt b/src/jit/CMakeLists.txt
index 816272f8b1..e8920a2860 100644
--- a/src/jit/CMakeLists.txt
+++ b/src/jit/CMakeLists.txt
@@ -236,9 +236,3 @@ if (CLR_CMAKE_PLATFORM_ARCH_I386 AND WIN32)
# (Note: we could also create linuxlegacynonjit for generating Linux/ARM32 code using LEGACY_BACKEND, if needed.)
add_subdirectory(legacynonjit)
endif (CLR_CMAKE_PLATFORM_ARCH_I386 AND WIN32)
-
-if (CLR_CMAKE_PLATFORM_ARCH_I386 AND WIN32)
- if (NOT CLR_BUILD_JIT32)
- add_subdirectory(compatjit)
- endif ()
-endif (CLR_CMAKE_PLATFORM_ARCH_I386 AND WIN32)