summaryrefslogtreecommitdiff
path: root/src/jit/CMakeLists.txt
diff options
context:
space:
mode:
authorJonghyun Park <parjong@gmail.com>2016-12-01 04:40:17 +0900
committerJan Vorlicek <janvorli@microsoft.com>2016-11-30 20:40:17 +0100
commit9883c466a5c73e3c3a9c6850e795071458abeb3b (patch)
tree8befb53b69c9a43d9747a9f0fb5f47fff6d91a81 /src/jit/CMakeLists.txt
parentfc46f78d8f1c2124a0a463dce5bcbba1f6929408 (diff)
downloadcoreclr-9883c466a5c73e3c3a9c6850e795071458abeb3b.tar.gz
coreclr-9883c466a5c73e3c3a9c6850e795071458abeb3b.tar.bz2
coreclr-9883c466a5c73e3c3a9c6850e795071458abeb3b.zip
[x86/Linux] Disable FEATURE_AVX_SUPPORT (#8335)
* Disable FEATURE_AVX_SUPPORT for x86/Linux This commit disables FEATURE_AVX_SUPPORT for x86/Linux to fix #8331. * Disable FEATURE_AVX_SUPPORT only for x86/Linux * Disable FEATURE_SIMD for x86/Linux * Simplify nested if in CMakeList.txt
Diffstat (limited to 'src/jit/CMakeLists.txt')
-rw-r--r--src/jit/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/jit/CMakeLists.txt b/src/jit/CMakeLists.txt
index fb3c1cab56..96b8c496b9 100644
--- a/src/jit/CMakeLists.txt
+++ b/src/jit/CMakeLists.txt
@@ -7,7 +7,7 @@ include_directories("../inc")
# Enable the following for UNIX altjit on Windows
# add_definitions(-DALT_JIT)
-if (CLR_CMAKE_TARGET_ARCH_AMD64 OR CLR_CMAKE_TARGET_ARCH_I386)
+if (CLR_CMAKE_TARGET_ARCH_AMD64 OR (CLR_CMAKE_TARGET_ARCH_I386 AND NOT CLR_CMAKE_PLATFORM_UNIX))
add_definitions(-DFEATURE_SIMD)
add_definitions(-DFEATURE_AVX_SUPPORT)
endif ()