summaryrefslogtreecommitdiff
path: root/src/inc/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2016-02-08 17:47:31 -0800
committerMike McLaughlin <mikem@microsoft.com>2016-02-10 13:38:08 -0800
commit7d74570d33823d4734fa287bc21a81ff12f7b40a (patch)
treea5c30abede3ac0679554444651fa1026288ae594 /src/inc/CMakeLists.txt
parentceb0a800ad650a36a32e543146669e9f3654e948 (diff)
downloadcoreclr-7d74570d33823d4734fa287bc21a81ff12f7b40a.tar.gz
coreclr-7d74570d33823d4734fa287bc21a81ff12f7b40a.tar.bz2
coreclr-7d74570d33823d4734fa287bc21a81ff12f7b40a.zip
Fix SOS managed breakpoints when coreclr symbols are stripped.
Added a SOS DAC interface (ISOSDacInterface4::GetClrNotification) to get the exception notification arguments instead of using the GetLastExceptionInformation function from the lldb sosplugin that depends on coreclr symbols being present. On the coreclr side, the clr notification arguments are saved in a global variable that is DAC accessible. A critical section was added to protect this global variable while the special exception is raised. Setting the internal COMPlus_DebugBreakOnAssert environment variable causes 3 or 4 breaks in the debugger with no reason. It was breaking in the function that was determining whether it should break. I was using COMPlus_BreakOnEELoad=2 to break after coreclr was loaded and initialized to set managed breakpoints and on a debug build it generates an assert (on release just a DebugBreak).
Diffstat (limited to 'src/inc/CMakeLists.txt')
-rw-r--r--src/inc/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/inc/CMakeLists.txt b/src/inc/CMakeLists.txt
index 9a59d48f9d..289ded3314 100644
--- a/src/inc/CMakeLists.txt
+++ b/src/inc/CMakeLists.txt
@@ -17,6 +17,7 @@ set( CORGUIDS_IDL_SOURCES
clrprivhosting.idl
clrprivruntimebinders.idl
corsym.idl
+ sospriv.idl
)
if(WIN32)