summaryrefslogtreecommitdiff
path: root/src/ildasm/CMakeLists.txt
diff options
context:
space:
mode:
authorKyungwoo Lee <kyulee@microsoft.com>2015-11-24 12:34:08 -0800
committerKyungwoo Lee <kyulee@microsoft.com>2015-11-25 11:58:52 -0800
commit1b6658714821566dd9ab78dcf1fe96fcb0f8772a (patch)
treec27daab52b3dbadd9cdf7620cb7b94ffceb2d62b /src/ildasm/CMakeLists.txt
parent6936820475b8c6b66de1807b0d123c195e18b868 (diff)
downloadcoreclr-1b6658714821566dd9ab78dcf1fe96fcb0f8772a.tar.gz
coreclr-1b6658714821566dd9ab78dcf1fe96fcb0f8772a.tar.bz2
coreclr-1b6658714821566dd9ab78dcf1fe96fcb0f8772a.zip
Enable ILDASM for Windows
This enables building ILDASM with Cmake for Windows. This ILDASM now depends on CoreCLR targeting cross-platform and thus I dropped some features like GUI/PDB -- default output is console. Metadata related APIs in CoreCLR are directly exported, and used in ILDASM: MetaDataGetDispenser GetMetaDataInternalInterface GetMetaDataInternalInterfaceFromPublic GetMetaDataPublicInterfaceFromInternal The code path is diverged by a definition FEATURE_CORECLR. There are still Window specific components. Among others, resource file/dll generation is the one that should be ported.
Diffstat (limited to 'src/ildasm/CMakeLists.txt')
-rw-r--r--src/ildasm/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/ildasm/CMakeLists.txt b/src/ildasm/CMakeLists.txt
new file mode 100644
index 0000000000..91ab76e066
--- /dev/null
+++ b/src/ildasm/CMakeLists.txt
@@ -0,0 +1,4 @@
+if (WIN32)
+ add_subdirectory(exe)
+ add_subdirectory(rcdll)
+endif()