summaryrefslogtreecommitdiff
path: root/src/gcinfo/CMakeLists.txt
diff options
context:
space:
mode:
authordotnet-bot <dotnet-bot@microsoft.com>2015-01-30 14:14:42 -0800
committerdotnet-bot <dotnet-bot@microsoft.com>2015-01-30 14:14:42 -0800
commitef1e2ab328087c61a6878c1e84f4fc5d710aebce (patch)
treedee1bbb89e9d722e16b0d1485e3cdd1b6c8e2cfa /src/gcinfo/CMakeLists.txt
downloadcoreclr-ef1e2ab328087c61a6878c1e84f4fc5d710aebce.tar.gz
coreclr-ef1e2ab328087c61a6878c1e84f4fc5d710aebce.tar.bz2
coreclr-ef1e2ab328087c61a6878c1e84f4fc5d710aebce.zip
Initial commit to populate CoreCLR repo
[tfs-changeset: 1407945]
Diffstat (limited to 'src/gcinfo/CMakeLists.txt')
-rw-r--r--src/gcinfo/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/gcinfo/CMakeLists.txt b/src/gcinfo/CMakeLists.txt
new file mode 100644
index 0000000000..528b9223ba
--- /dev/null
+++ b/src/gcinfo/CMakeLists.txt
@@ -0,0 +1,16 @@
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set( GCINFO_SOURCES
+ gcinfoencoder.cpp
+ dbggcinfoencoder.cpp
+)
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+add_library(gcinfo
+ STATIC
+ ${GCINFO_SOURCES}
+)