summaryrefslogtreecommitdiff
path: root/src/dlls/mscordbi/CMakeLists.txt
diff options
context:
space:
mode:
authorRahul Kumar <rahku@microsoft.com>2016-04-19 14:22:23 -0700
committerRahul Kumar <rahku@microsoft.com>2016-04-26 10:12:06 -0700
commit27fc507393a641542a939168b41585895b6b4fc2 (patch)
tree4e979ea708fe9af0987087a155cf27135e049e97 /src/dlls/mscordbi/CMakeLists.txt
parent5fe61b36cc72d43263fc892c754bb9f46acb5ef5 (diff)
downloadcoreclr-27fc507393a641542a939168b41585895b6b4fc2.tar.gz
coreclr-27fc507393a641542a939168b41585895b6b4fc2.tar.bz2
coreclr-27fc507393a641542a939168b41585895b6b4fc2.zip
This has following changes:
1. Update arm64 toolset to latest. 2. Link against ucrt. 3. Fix tls offsets which have changed due to updated toolset 4. Fix source code in decimal.cpp to avoid integer overflow. Result of signed integer overlfow is undefined in C++. 5. Enable build of sos which can be loaded in arm64 windbg 6. Add nop to empty assembly marker methods as new toolset generates invalid .pdata for them.
Diffstat (limited to 'src/dlls/mscordbi/CMakeLists.txt')
-rw-r--r--src/dlls/mscordbi/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/dlls/mscordbi/CMakeLists.txt b/src/dlls/mscordbi/CMakeLists.txt
index b8dfa71ca6..28b006b58c 100644
--- a/src/dlls/mscordbi/CMakeLists.txt
+++ b/src/dlls/mscordbi/CMakeLists.txt
@@ -62,15 +62,9 @@ if(WIN32)
user32.lib
version.lib
${STATIC_MT_CRT_LIB}
+ ${STATIC_MT_VCRT_LIB}
)
- # ARM64_TODO: Enable this for Windows Arm64
- if (NOT CLR_CMAKE_PLATFORM_ARCH_ARM64)
- list(APPEND COREDBI_LIBRARIES
- ${STATIC_MT_VCRT_LIB}
- )
- endif()
-
target_link_libraries(mscordbi ${COREDBI_LIBRARIES})
elseif(CLR_CMAKE_PLATFORM_UNIX)