summaryrefslogtreecommitdiff
path: root/src/dlls/CMakeLists.txt
diff options
context:
space:
mode:
authorHyeongseok Oh <hseok82.oh@samsung.com>2017-03-29 17:28:57 +0900
committerJan Vorlicek <janvorli@microsoft.com>2017-03-29 10:28:57 +0200
commit1c4fda612e8a4f0d48346c477d058fa3fddf514e (patch)
treee5f8c1dcbd7d4424a0a05a917b976e9514c0cd2b /src/dlls/CMakeLists.txt
parenta1ad1592f45bdfc544deedb1d2e88e9a35895bb1 (diff)
downloadcoreclr-1c4fda612e8a4f0d48346c477d058fa3fddf514e.tar.gz
coreclr-1c4fda612e8a4f0d48346c477d058fa3fddf514e.tar.bz2
coreclr-1c4fda612e8a4f0d48346c477d058fa3fddf514e.zip
Fix dependency to coreclr and mscorrc in Linux (#10138)
* Fix dependency to coreclr and mscorrc in Linux Remove dependency with coreclr in some projects for Linux Recover build mscorrc for cross architecture in Linux * Fix CMakeLists.txt in src/dlls minimize uses of CLR_CROSS_COMPONENTS_BUILD flag in CMakeLists.txt Modify root/CMakeLists.txt to exclude corerun and coreconsole build during cross component build
Diffstat (limited to 'src/dlls/CMakeLists.txt')
-rw-r--r--src/dlls/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/dlls/CMakeLists.txt b/src/dlls/CMakeLists.txt
index 6d036aff66..932e65e350 100644
--- a/src/dlls/CMakeLists.txt
+++ b/src/dlls/CMakeLists.txt
@@ -4,8 +4,6 @@ endif(WIN32)
add_subdirectory(dbgshim)
add_subdirectory(mscordbi)
add_subdirectory(mscordac)
-if (NOT CLR_CROSS_COMPONENTS_BUILD)
- add_subdirectory(mscoree)
- add_subdirectory(mscorpe)
- add_subdirectory(mscorrc)
-endif()
+add_subdirectory(mscoree)
+add_subdirectory(mscorpe)
+add_subdirectory(mscorrc)