summaryrefslogtreecommitdiff
path: root/src/debug/debug-pal/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2015-06-10 16:54:02 -0700
committerMike McLaughlin <mikem@microsoft.com>2015-06-15 12:52:22 -0700
commita7f11f2268c5df943fa952d49a1203c88209ae3c (patch)
tree0fb7f3264b7b41dbb98c162e9eaa9ccdbbba80c4 /src/debug/debug-pal/CMakeLists.txt
parent11b9438b15629b7d60816de07bf1139f521cf3be (diff)
downloadcoreclr-a7f11f2268c5df943fa952d49a1203c88209ae3c.tar.gz
coreclr-a7f11f2268c5df943fa952d49a1203c88209ae3c.tar.bz2
coreclr-a7f11f2268c5df943fa952d49a1203c88209ae3c.zip
Fully implement dbgshim so it doesn't depend on LD_LIBRARY_PATH (issue #650).
It finds and uses the path coreclr is in to load dbi/dac. EnumProcessModules returns an array of module base addresses and GetModuleFileNameEx takes the base address and returns the module name string. Fixed directory separator in dbgshim.
Diffstat (limited to 'src/debug/debug-pal/CMakeLists.txt')
-rw-r--r--src/debug/debug-pal/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/debug/debug-pal/CMakeLists.txt b/src/debug/debug-pal/CMakeLists.txt
index 01284029dc..43c1c9fdbe 100644
--- a/src/debug/debug-pal/CMakeLists.txt
+++ b/src/debug/debug-pal/CMakeLists.txt
@@ -23,7 +23,6 @@ if(CLR_CMAKE_PLATFORM_UNIX)
set(TWO_WAY_PIPE_SOURCES
unix/twowaypipe.cpp
- unix/dynamiclibaddress.cpp
)
endif(CLR_CMAKE_PLATFORM_UNIX)