summaryrefslogtreecommitdiff
path: root/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2015-02-20 15:10:11 -0800
committerMike McLaughlin <mikem@microsoft.com>2015-02-20 15:10:11 -0800
commitd6cf26f985fa5645fb8137d069a273e111041464 (patch)
tree9a8c865c7b4a5026ac43b29950012d44d0868bfb /src/ToolBox/SOS/lldbplugin/CMakeLists.txt
parent0fd6f997279d1b11c977a1213ddbc044e8f3af30 (diff)
downloadcoreclr-d6cf26f985fa5645fb8137d069a273e111041464.tar.gz
coreclr-d6cf26f985fa5645fb8137d069a273e111041464.tar.bz2
coreclr-d6cf26f985fa5645fb8137d069a273e111041464.zip
More review feedback changes. Fixed message when the sos module isn't found. Changed the plugin make file to build on OSx only if the environment vars are set. Fixed IP2MD command on windows.
Diffstat (limited to 'src/ToolBox/SOS/lldbplugin/CMakeLists.txt')
-rw-r--r--src/ToolBox/SOS/lldbplugin/CMakeLists.txt34
1 files changed, 18 insertions, 16 deletions
diff --git a/src/ToolBox/SOS/lldbplugin/CMakeLists.txt b/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
index 98295ec4d8..78046ec316 100644
--- a/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
+++ b/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
@@ -6,30 +6,32 @@ if((NOT $ENV{LLDB_INCLUDE_DIR} STREQUAL "") AND (NOT $ENV{LLDB_LIB_DIR} STREQUAL
# The OSx build depends on the environment variables LLDB_INCLUDE_DIR and LLDB_LIB_DIR being set
set(LLDB_INCLUDE_DIR "$ENV{LLDB_INCLUDE_DIR}")
set(LLDB_LIB_DIR "$ENV{LLDB_LIB_DIR}")
-else()
+elseif(CLR_CMAKE_PLATFORM_LINUX)
# The Linux build depends on the lldb-3.5-dev package
set(LLVM_DIR "/usr/lib/llvm-3.5")
set(LLDB_INCLUDE_DIR "${LLVM_DIR}/include")
set(LLDB_LIB_DIR "${LLVM_DIR}/lib")
endif()
-message(LLDB_INCLUDE_DIR=${LLDB_INCLUDE_DIR})
-message(LLDB_LIB_DIR=${LLDB_LIB_DIR})
+if((NOT ${LLDB_INCLUDE_DIR} STREQUAL "") AND (NOT ${LLDB_LIB_DIR} STREQUAL ""))
+ message(LLDB_INCLUDE_DIR=${LLDB_INCLUDE_DIR})
+ message(LLDB_LIB_DIR=${LLDB_LIB_DIR})
-add_compile_options(-Wno-delete-non-virtual-dtor)
+ add_compile_options(-Wno-delete-non-virtual-dtor)
-include_directories(inc)
-include_directories("${LLDB_INCLUDE_DIR}")
-link_directories("${LLDB_LIB_DIR}")
+ include_directories(inc)
+ include_directories("${LLDB_INCLUDE_DIR}")
+ link_directories("${LLDB_LIB_DIR}")
-set(SOURCES
- sosplugin.cpp
- soscommand.cpp
- debugclient.cpp
-)
+ set(SOURCES
+ sosplugin.cpp
+ soscommand.cpp
+ debugclient.cpp
+ )
-add_library(sosplugin SHARED ${SOURCES})
-add_dependencies(sosplugin sos)
+ add_library(sosplugin SHARED ${SOURCES})
+ add_dependencies(sosplugin sos)
-# add the install targets
-install (TARGETS sosplugin DESTINATION .) \ No newline at end of file
+ # add the install targets
+ install (TARGETS sosplugin DESTINATION .)
+endif() \ No newline at end of file