summaryrefslogtreecommitdiff
path: root/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2015-02-23 19:56:59 -0800
committerMike McLaughlin <mikem@microsoft.com>2015-02-23 19:56:59 -0800
commitc749150613fe0d7e043b98c2e4e8151f32dbcbb4 (patch)
treea6455b609c4f3c37375ac918b365d22dec597f8b /src/ToolBox/SOS/lldbplugin/CMakeLists.txt
parentee514ac0eb5f4231d191f3c0c4f5cb582747177d (diff)
downloadcoreclr-c749150613fe0d7e043b98c2e4e8151f32dbcbb4.tar.gz
coreclr-c749150613fe0d7e043b98c2e4e8151f32dbcbb4.tar.bz2
coreclr-c749150613fe0d7e043b98c2e4e8151f32dbcbb4.zip
Add check for lldb-3.5-dev package and enable lldb sos plugin build.
Diffstat (limited to 'src/ToolBox/SOS/lldbplugin/CMakeLists.txt')
-rw-r--r--src/ToolBox/SOS/lldbplugin/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/ToolBox/SOS/lldbplugin/CMakeLists.txt b/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
index 5fb5f62a05..614e9827b0 100644
--- a/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
+++ b/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
@@ -8,10 +8,9 @@ if((NOT $ENV{LLDB_INCLUDE_DIR} STREQUAL "") AND (NOT $ENV{LLDB_LIB_DIR} STREQUAL
set(LLDB_LIB_DIR "$ENV{LLDB_LIB_DIR}")
elseif(CLR_CMAKE_PLATFORM_LINUX)
# The Linux build depends on the lldb-3.5-dev package
- # TODO 2/23/15 - temporary until we get the lldb-3.5-dev package installed on the CI machine.
- #set(LLVM_DIR "/usr/lib/llvm-3.5")
- #set(LLDB_INCLUDE_DIR "${LLVM_DIR}/include")
- #set(LLDB_LIB_DIR "${LLVM_DIR}/lib")
+ set(LLVM_DIR "/usr/lib/llvm-3.5")
+ set(LLDB_INCLUDE_DIR "${LLVM_DIR}/include")
+ set(LLDB_LIB_DIR "${LLVM_DIR}/lib")
endif()
if((NOT ${LLDB_INCLUDE_DIR} STREQUAL "") AND (NOT ${LLDB_LIB_DIR} STREQUAL ""))