summaryrefslogtreecommitdiff
path: root/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2015-02-20 14:13:03 -0800
committerMike McLaughlin <mikem@microsoft.com>2015-02-20 14:13:03 -0800
commit67d2897c6e923bccc56956f63e9bda8576d1982f (patch)
tree38b05086c19ae0647692f450381a83632c9033ed /src/ToolBox/SOS/lldbplugin/CMakeLists.txt
parent44d3087a4d91473a9b5ed0975eff5891ac3b9976 (diff)
downloadcoreclr-67d2897c6e923bccc56956f63e9bda8576d1982f.tar.gz
coreclr-67d2897c6e923bccc56956f63e9bda8576d1982f.tar.bz2
coreclr-67d2897c6e923bccc56956f63e9bda8576d1982f.zip
Review feedback. Fixed the sos plugin make file to use the LLDB_INCLUDE_DIR and LLDB_LIB_DIR environment variables if set. Otherwise, it assumes the lldb-3.5-dev package is installed.
Diffstat (limited to 'src/ToolBox/SOS/lldbplugin/CMakeLists.txt')
-rw-r--r--src/ToolBox/SOS/lldbplugin/CMakeLists.txt16
1 files changed, 13 insertions, 3 deletions
diff --git a/src/ToolBox/SOS/lldbplugin/CMakeLists.txt b/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
index 4405c40ae1..98295ec4d8 100644
--- a/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
+++ b/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
@@ -2,9 +2,19 @@ project(sosplugin)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
-set(LLVM_DIR "/usr/lib/llvm-3.5")
-set(LLDB_INCLUDE_DIR "${LLVM_DIR}/include")
-set(LLDB_LIB_DIR "${LLVM_DIR}/lib")
+if((NOT $ENV{LLDB_INCLUDE_DIR} STREQUAL "") AND (NOT $ENV{LLDB_LIB_DIR} STREQUAL ""))
+ # The OSx build depends on the environment variables LLDB_INCLUDE_DIR and LLDB_LIB_DIR being set
+ set(LLDB_INCLUDE_DIR "$ENV{LLDB_INCLUDE_DIR}")
+ set(LLDB_LIB_DIR "$ENV{LLDB_LIB_DIR}")
+else()
+ # The Linux build depends on the lldb-3.5-dev package
+ set(LLVM_DIR "/usr/lib/llvm-3.5")
+ set(LLDB_INCLUDE_DIR "${LLVM_DIR}/include")
+ set(LLDB_LIB_DIR "${LLVM_DIR}/lib")
+endif()
+
+message(LLDB_INCLUDE_DIR=${LLDB_INCLUDE_DIR})
+message(LLDB_LIB_DIR=${LLDB_LIB_DIR})
add_compile_options(-Wno-delete-non-virtual-dtor)