summaryrefslogtreecommitdiff
path: root/src/ToolBox/SOS/DacTableGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJiyoung Yun <jy910.yun@samsung.com>2016-11-23 19:09:09 +0900
committerJiyoung Yun <jy910.yun@samsung.com>2016-11-23 19:09:09 +0900
commit4b4aad7217d3292650e77eec2cf4c198ea9c3b4b (patch)
tree98110734c91668dfdbb126fcc0e15ddbd93738ca /src/ToolBox/SOS/DacTableGen/CMakeLists.txt
parentfa45f57ed55137c75ac870356a1b8f76c84b229c (diff)
downloadcoreclr-4b4aad7217d3292650e77eec2cf4c198ea9c3b4b.tar.gz
coreclr-4b4aad7217d3292650e77eec2cf4c198ea9c3b4b.tar.bz2
coreclr-4b4aad7217d3292650e77eec2cf4c198ea9c3b4b.zip
Imported Upstream version 1.1.0upstream/1.1.0
Diffstat (limited to 'src/ToolBox/SOS/DacTableGen/CMakeLists.txt')
-rw-r--r--src/ToolBox/SOS/DacTableGen/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/ToolBox/SOS/DacTableGen/CMakeLists.txt b/src/ToolBox/SOS/DacTableGen/CMakeLists.txt
new file mode 100644
index 0000000000..01ee51f7a4
--- /dev/null
+++ b/src/ToolBox/SOS/DacTableGen/CMakeLists.txt
@@ -0,0 +1,19 @@
+set(DACTABLEGEN_SOURCES
+ cvconst.cs
+ diautil.cs
+ main.cs
+ MapSymbolProvider.cs
+)
+
+# Cmake does not support csharp sources so add custom command
+add_custom_target(dactablegen ALL
+ COMMAND csc.exe /t:exe /platform:anycpu /r:System.dll /r:$<TARGET_FILE:dialib_dll> /out:${CMAKE_CURRENT_BINARY_DIR}/dactablegen.exe ${DACTABLEGEN_SOURCES}
+ COMMAND ${CMAKE_COMMAND} -E copy $<TARGET_FILE:dialib_dll> $<TARGET_FILE_DIR:dactablegen_exe>
+ DEPENDS ${DACTABLEGEN_SOURCES} dialib
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+)
+
+# In order to use dactablegen as an executable target it needs to be imported.
+# Target is used in dll/mscoree/coreclr/cmakelists.txt
+add_executable(dactablegen_exe IMPORTED GLOBAL)
+set_property(TARGET dactablegen_exe PROPERTY IMPORTED_LOCATION ${CMAKE_CURRENT_BINARY_DIR}/dactablegen.exe) \ No newline at end of file