summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKyungwoo Lee <kyulee@microsoft.com>2015-12-08 14:26:54 -0800
committerKyungwoo Lee <kyulee@microsoft.com>2015-12-09 17:43:10 -0800
commitc09a2320ed6184f2ad0f0c59cdd6884c76c9e038 (patch)
treeec7fb163cb438237d19fdc849d121f84c3dbdac5 /src/CMakeLists.txt
parentd1633211ee01ed05f467cacd36418f313e7a3d71 (diff)
downloadcoreclr-c09a2320ed6184f2ad0f0c59cdd6884c76c9e038.tar.gz
coreclr-c09a2320ed6184f2ad0f0c59cdd6884c76c9e038.tar.bz2
coreclr-c09a2320ed6184f2ad0f0c59cdd6884c76c9e038.zip
Enable ILASM for Windows
This enables ILASM/mscorpe on CoreCLR for Windows. 1. Fusion/StrongName(Full Sign) dependencies are removed since these are not CoreCLR features. 2. mscorpe is statically built/linked to ilasm. 3. asmparse.c is auto-generated by an internal version of yacc so I added it under prebuilt directory for now. Will create an issue so that we can build it using a standard tool like bison.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7949679f8e..64d7d63f80 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -88,6 +88,7 @@ add_subdirectory(unwinder)
add_subdirectory(ildasm)
if(WIN32)
+ add_subdirectory(ilasm)
add_subdirectory(ipcman)
endif(WIN32)