summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSean Gillespie <segilles@microsoft.com>2017-08-22 10:20:36 -0700
committerGitHub <noreply@github.com>2017-08-22 10:20:36 -0700
commit8acf6c9f7e33b1bfe77205cd2e61f2c60e8c00ce (patch)
tree5f7e55f04b5182a6ef1bd537ef76accd5a494782 /src/CMakeLists.txt
parent2766385624a9c5b73d32bed85519c044447701ff (diff)
downloadcoreclr-8acf6c9f7e33b1bfe77205cd2e61f2c60e8c00ce.tar.gz
coreclr-8acf6c9f7e33b1bfe77205cd2e61f2c60e8c00ce.tar.bz2
coreclr-8acf6c9f7e33b1bfe77205cd2e61f2c60e8c00ce.zip
[Local GC] Enable building the GC as a shared library (#13137)
* [Local GC] Build the GC using system headers * Disable features to get the GC to build * Get rid of the separate 'GC PAL' build * Remove unused stuff * Don't build gcenv.os.cpp when linking in a standalone gc * Stub out CPUGroupInfo and NumaNodeInfo * Stub out IsGCThread and friends * Build the GC as a shared library :tada: * Build, link, and run! :tada: * Fix standalone GC build break * Fixes where the GC's MethodTable and VM's MethodTable classes disagree * Integrate a standalone GC into the CoreCLR build system (so it gets copied to the output folder). Re-enable some ifdef-ed out includes that are required for a non-standalone build of the GC. * Bring changes to Unix and fix the Unix build. Implement some compiler intrinsic wrappers and alignment functions expected by the GC. * Fix the Windows build * 1. Code review feedback: use standard types for BitScanForward and BitScanForward64 2. Delete FEATURE_COM stuff from the build system, not needed for this PR 3. Fix the Unix build * Fix the Windows x86 build - the _BitScanForward64 intrinsic is not available when targeting 32-bit platforms * Remove a number of things from gcenv.base.h that are not used * Remove a linker workaround now that we are not linking a standalone GC into the runtime * Remove dead code, make the lack of GC_PROFILING for standalone gc not break profiling on the non-standalone build * Code review feedback - use add_library_clr and other cmake-related fixes * Fix include indentation * Remove some extraneous parameters to cmake functions (cmake is remarkably lenient...)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ba17dc05ce..900ba96f53 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -155,9 +155,6 @@ add_subdirectory(utilcode)
add_subdirectory(gcinfo)
add_subdirectory(coreclr)
add_subdirectory(jit)
-if(FEATURE_STANDALONE_GC)
- add_subdirectory(gc)
-endif(FEATURE_STANDALONE_GC)
add_subdirectory(vm)
add_subdirectory(md)
add_subdirectory(debug)