summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Vorlicek <janvorli@microsoft.com>2017-09-13 23:33:55 +0200
committerGitHub <noreply@github.com>2017-09-13 23:33:55 +0200
commit9fc84cfb5feafe7846307d76df2b9f85455b481a (patch)
treee8efa8953966ad40b53ae439f894ff06c169c799 /src/CMakeLists.txt
parente866d072042f4ad9e0811aa36e338dac781c09a5 (diff)
downloadcoreclr-9fc84cfb5feafe7846307d76df2b9f85455b481a.tar.gz
coreclr-9fc84cfb5feafe7846307d76df2b9f85455b481a.tar.bz2
coreclr-9fc84cfb5feafe7846307d76df2b9f85455b481a.zip
Fix setting PAX options for crossgen (#13950)
In my previous PR that added marking executables with paxctl, I've made a mistake in the order of calling _add_library and add_dependencies. But that was hidden due to the fact that we have yet another copy of the add_library_clr and add_executable_clr functions in src/CMakeLists.txt. I have no idea how that happened. This one has overriden the other, which has hidden the problem, but also caused the crossgen to not to be modified by the paxctl. So I am fixing the order and removing the extra definitions of those functions.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt26
1 files changed, 0 insertions, 26 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 900ba96f53..4c999b184d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -75,32 +75,6 @@ add_custom_target(
DEPENDS ${GeneratedEventFiles}
)
-function(add_library_clr)
- if(NOT WIN32)
- add_library(${ARGV} ${VERSION_FILE_PATH})
- else()
- add_library(${ARGV})
- endif(NOT WIN32)
- add_dependencies(${ARGV0} GeneratedEventingFiles)
- list(FIND CLR_CROSS_COMPONENTS_LIST ${ARGV0} INDEX)
- if (DEFINED CLR_CROSS_COMPONENTS_LIST AND ${INDEX} EQUAL -1)
- set_target_properties(${ARGV0} PROPERTIES EXCLUDE_FROM_ALL 1)
- endif()
-endfunction()
-
-function(add_executable_clr)
- if(NOT WIN32)
- add_executable(${ARGV} ${VERSION_FILE_PATH})
- else()
- add_executable(${ARGV})
- endif(NOT WIN32)
- add_dependencies(${ARGV0} GeneratedEventingFiles)
- list(FIND CLR_CROSS_COMPONENTS_LIST ${ARGV0} INDEX)
- if (DEFINED CLR_CROSS_COMPONENTS_LIST AND ${INDEX} EQUAL -1)
- set_target_properties(${ARGV0} PROPERTIES EXCLUDE_FROM_ALL 1)
- endif()
-endfunction()
-
if(CLR_CMAKE_PLATFORM_UNIX)
if(CLR_CMAKE_PLATFORM_LINUX)
if(CLR_CMAKE_PLATFORM_UNIX_AMD64 OR CLR_CMAKE_PLATFORM_UNIX_ARM)