summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorVictor "Nate" Graf <nategraf1@gmail.com>2018-01-02 09:47:20 -0800
committerGitHub <noreply@github.com>2018-01-02 09:47:20 -0800
commitc1bbdae7964b19b7063074d36e6af960f0cdc3a0 (patch)
treee554fc74fbb22c6ce9dd488fb02ba4f08ee89e89 /src/CMakeLists.txt
parent35bba0c5b29e9dfd2744b09e577f6111ef7de9d7 (diff)
downloadcoreclr-c1bbdae7964b19b7063074d36e6af960f0cdc3a0.tar.gz
coreclr-c1bbdae7964b19b7063074d36e6af960f0cdc3a0.tar.bz2
coreclr-c1bbdae7964b19b7063074d36e6af960f0cdc3a0.zip
Retry: Enable EventPipe across Unix and Windows (#15611)
* Revert "Revert "Enable EventPipe across Unix and Windows (#14772)" (#15609)" This reverts commit 302005ca8ae14eade37ddf4ac6e900617c1c166a. * Fix ARM build break * Use more explicit references to resolve build failures * Fix compat with python3 * Disable FeaturePerfTracing on Windows as it is not ready * Disable test for incomplete functionality * Fix test diabled patterns * Add license header * Use keyword types for managed code * Add message prefix * More precisly condition generation of eventing sources * Remove erroneously added changes
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt66
1 files changed, 3 insertions, 63 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4c999b184d..0412226dfc 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -10,70 +10,10 @@ include_directories("classlibnative/cryptography")
include_directories("classlibnative/inc")
include_directories("${GENERATED_INCLUDE_DIR}")
-# The Following Logic is used to wire up Build dependencies for Generated files in Event Logging
-# ClrEtwAll.man - Event Schema
-# ClrEtwAllMeta.lst - MetaData list [provided to ensure Windows Desktop is not broken]
-# genXplatEventing.py - has the core logic for parsing Event Schema
-# genWinEtw.py - Uses genXplatEventing to generate Windows Specific ETW Files
-# clretwallmain.h and etmdummy.h - Provides the Event Logging Functionality to the VM
-# clrxplatevents.h - Used by clretwallmain.h on Non Windows platform
-# ClrEtwAll.h - Used by clretwallmain.h on Windows
-# ClrEtwAll.rc - Used by src/dlls/clretwrc/clretrw.rc on Windows
-
-set (ScriptGeneratedEventFiles
- ${GENERATED_INCLUDE_DIR}/clretwallmain.h
- ${GENERATED_INCLUDE_DIR}/etmdummy.h
-)
-set (GeneratedEventFiles)
+if(WIN32 AND FEATURE_EVENT_TRACE)
+ include_directories("${GENERATED_INCLUDE_DIR}/etw")
+endif(WIN32 AND FEATURE_EVENT_TRACE)
-if(WIN32)
- set (GenEventFilesScript "${CLR_DIR}/src/scripts/genWinEtw.py")
- set (GenEventArgs --eventheader "${GENERATED_INCLUDE_DIR}/ClrEtwAll.h" --macroheader "${GENERATED_INCLUDE_DIR}/clretwallmain.h")
-
- list (APPEND ScriptGeneratedEventFiles
- ${GENERATED_INCLUDE_DIR}/ClrEtwAll.h
- )
-
- list (APPEND GeneratedEventFiles
- ${GENERATED_INCLUDE_DIR}/ClrEtwAll.rc
- )
-
- add_custom_command(
- COMMENT "Generating ETW resource Files"
- COMMAND ${MC} -h ${GENERATED_INCLUDE_DIR} -r ${GENERATED_INCLUDE_DIR} -b -co -um -p FireEtw "${VM_DIR}/ClrEtwAll.man"
- OUTPUT ${GENERATED_INCLUDE_DIR}/ClrEtwAll.h
- DEPENDS "${VM_DIR}/ClrEtwAll.man"
- )
-else()
- set (GenEventFilesScript "${CLR_DIR}/src/scripts/genXplatEventing.py")
- set (GenEventArgs --inc "${GENERATED_INCLUDE_DIR}")
-
- list (APPEND ScriptGeneratedEventFiles
- ${GENERATED_INCLUDE_DIR}/clrxplatevents.h
- )
-endif(WIN32)
-
-if(CLR_CMAKE_WARNINGS_ARE_ERRORS)
- set(PYTHON_WARNING_FLAGS -Wall -Werror)
-else()
- set(PYTHON_WARNING_FLAGS -Wall)
-endif(CLR_CMAKE_WARNINGS_ARE_ERRORS)
-
-add_custom_command(
- COMMENT "Generating Eventing Files"
- COMMAND ${PYTHON} -B ${PYTHON_WARNING_FLAGS} ${GenEventFilesScript} ${GenEventArgs} --man "${VM_DIR}/ClrEtwAll.man" --exc "${VM_DIR}/ClrEtwAllMeta.lst" --dummy "${GENERATED_INCLUDE_DIR}/etmdummy.h"
- OUTPUT ${ScriptGeneratedEventFiles}
- DEPENDS ${GenEventFilesScript} "${VM_DIR}/ClrEtwAll.man" "${VM_DIR}/ClrEtwAllMeta.lst" "${CLR_DIR}/src/scripts/genXplatEventing.py"
-)
-
-list (APPEND GeneratedEventFiles
- ${ScriptGeneratedEventFiles}
-)
-
-add_custom_target(
- GeneratedEventingFiles
- DEPENDS ${GeneratedEventFiles}
-)
if(CLR_CMAKE_PLATFORM_UNIX)
if(CLR_CMAKE_PLATFORM_LINUX)