summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRahul Kumar <rahku@microsoft.com>2016-04-12 14:40:23 -0700
committerRahul Kumar <rahku@microsoft.com>2016-04-18 22:17:29 -0700
commit7f46dbe0c6b0785a4e40978da684b1dc81d0b8ce (patch)
tree2de78686eb771e11d7276c69791405550bbd0311 /src/CMakeLists.txt
parent0a31fe90800bd45e3c3668483dbe27358864170e (diff)
downloadcoreclr-7f46dbe0c6b0785a4e40978da684b1dc81d0b8ce.tar.gz
coreclr-7f46dbe0c6b0785a4e40978da684b1dc81d0b8ce.tar.bz2
coreclr-7f46dbe0c6b0785a4e40978da684b1dc81d0b8ce.zip
enable build of cross target components.
Currently only enabled for arm64
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 957be0ef38..323c6f2e4f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -72,11 +72,19 @@ add_custom_target(
function(add_library_clr)
add_library(${ARGV})
add_dependencies(${ARGV0} GeneratedEventingFiles)
+ list(FIND CLR_CROSS_COMPONENTS_LIST ${ARGV0} INDEX)
+ if (DEFINED CLR_CROSS_COMPONENTS_LIST AND ${INDEX} EQUAL -1)
+ set_target_properties(${ARGV0} PROPERTIES EXCLUDE_FROM_ALL 1)
+ endif()
endfunction()
function(add_executable_clr)
add_executable(${ARGV})
add_dependencies(${ARGV0} GeneratedEventingFiles)
+ list(FIND CLR_CROSS_COMPONENTS_LIST ${ARGV0} INDEX)
+ if (DEFINED CLR_CROSS_COMPONENTS_LIST AND ${INDEX} EQUAL -1)
+ set_target_properties(${ARGV0} PROPERTIES EXCLUDE_FROM_ALL 1)
+ endif()
endfunction()
if(CLR_CMAKE_PLATFORM_UNIX)