summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Perez Rodriguez <joperezr@microsoft.com>2016-04-21 08:45:23 -0700
committerJose Perez Rodriguez <joperezr@microsoft.com>2016-04-21 08:45:23 -0700
commit250a206c98d8e3992512246e02bf0820ef95578b (patch)
tree0b9ad3f2d0ae1521220e6aeacb29234f0e44085a /src/CMakeLists.txt
parent65547d0c86120b0cfd89609e2cb12b6eb7b10c83 (diff)
downloadcoreclr-250a206c98d8e3992512246e02bf0820ef95578b.tar.gz
coreclr-250a206c98d8e3992512246e02bf0820ef95578b.tar.bz2
coreclr-250a206c98d8e3992512246e02bf0820ef95578b.zip
Adding Versioning to Native components in non-Windows builds. (#4393)
Adding Versioning to Native components in non-Windows builds.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 323c6f2e4f..70f436c6c3 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -70,7 +70,11 @@ add_custom_target(
)
function(add_library_clr)
- add_library(${ARGV})
+ if(NOT WIN32)
+ add_library(${ARGV} ${VERSION_FILE_PATH})
+ else()
+ add_library(${ARGV})
+ endif(NOT WIN32)
add_dependencies(${ARGV0} GeneratedEventingFiles)
list(FIND CLR_CROSS_COMPONENTS_LIST ${ARGV0} INDEX)
if (DEFINED CLR_CROSS_COMPONENTS_LIST AND ${INDEX} EQUAL -1)
@@ -79,7 +83,11 @@ function(add_library_clr)
endfunction()
function(add_executable_clr)
- add_executable(${ARGV})
+ if(NOT WIN32)
+ add_executable(${ARGV} ${VERSION_FILE_PATH})
+ else()
+ add_executable(${ARGV})
+ endif(NOT WIN32)
add_dependencies(${ARGV0} GeneratedEventingFiles)
list(FIND CLR_CROSS_COMPONENTS_LIST ${ARGV0} INDEX)
if (DEFINED CLR_CROSS_COMPONENTS_LIST AND ${INDEX} EQUAL -1)