summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authormikem8361 <mikem@microsoft.com>2015-02-12 15:53:26 -0800
committermikem8361 <mikem@microsoft.com>2015-02-12 15:53:26 -0800
commit860bb3814069e57ed956449603ef24f520c25e23 (patch)
treedf689881ab97b9a3429e9cfad871fd11253c493f /src/CMakeLists.txt
parent0084af0bc3f8761599e0c11b73489cfa53d810a4 (diff)
downloadcoreclr-860bb3814069e57ed956449603ef24f520c25e23.tar.gz
coreclr-860bb3814069e57ed956449603ef24f520c25e23.tar.bz2
coreclr-860bb3814069e57ed956449603ef24f520c25e23.zip
These changes are the beginning of the SOS for coreclr under lldb. It isn't finished or working yet.
The sos plug in is broken into two modules: 1) The lldb plugin (sosplugin) module that is built with the lldb h and lib files. This module dynamically loads the sos module and finds the subcommand argument as a symbol export like windbg does for it's extensions. So "sos IP2MD 0x100000" loads sos, finds the export "IP2MD" and calls it with the rest of the command and a "IDebugClient" instance. This instance is a small subset of the the various dbgeng's API's implemented under lldb without any COM to keep things simple. OPEN ISSUE: This module's build depends on the lldb API includes and the lldb library. Need to figure out the best way to deal with the dependency on the lldb source. 2) The sos module (sos) module that is the strike source built under linux. Currently only the IP2MD command is built and the support/utility functions it needs. It dynamically loads the DAC (libmscordaccore.so) and queries the IXCLRDataProcess interface via the DAC's CLRDataCreateInstance export. OPEN ISSUE: Where and how to search for the sos/dac modules. Currently have a hard coded path to the binaries. It probably should be the directory the plug in (sosplugin) is loaded.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6401672e54..95a56e1baa 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -36,11 +36,11 @@ add_subdirectory(strongname)
add_subdirectory(binder)
add_subdirectory(classlibnative)
add_subdirectory(dlls)
+add_subdirectory(ToolBox)
add_subdirectory(unwinder)
if(WIN32)
add_subdirectory(ipcman)
- add_subdirectory(ToolBox)
add_subdirectory(tools)
endif(WIN32)