summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJuan Hoyos <juan.hoyos@microsoft.com>2019-06-17 10:22:13 -0700
committerGitHub <noreply@github.com>2019-06-17 10:22:13 -0700
commit6f1d3b4af924d22d2830d44c47a008ac1c284d7e (patch)
tree01c683ece2176b3e0a90200ea083aae710fd3d2e /src/CMakeLists.txt
parente1a00802f9873eeb3d46ce8fd05d0ac1ddfb400f (diff)
downloadcoreclr-6f1d3b4af924d22d2830d44c47a008ac1c284d7e.tar.gz
coreclr-6f1d3b4af924d22d2830d44c47a008ac1c284d7e.tar.bz2
coreclr-6f1d3b4af924d22d2830d44c47a008ac1c284d7e.zip
Enable createdump on arm and arm64 (#24832)
* Enable build of ARM64 createdump build - Adds definitions of necessary constructs and aligments for Elf formats in aarch64 - Work around changes in ptrace for aarch64 * Package createdump in runtime transport for arm and arm64 * Use special name register definitions from the PAL * Add createdump_lib to arm64 sos and package plugin
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 51ce71e598..f4542b3133 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -16,10 +16,8 @@ endif(WIN32 AND FEATURE_EVENT_TRACE)
if(CLR_CMAKE_PLATFORM_UNIX)
- if(CLR_CMAKE_PLATFORM_LINUX)
- if(CLR_CMAKE_PLATFORM_UNIX_AMD64 OR CLR_CMAKE_PLATFORM_UNIX_ARM)
- add_subdirectory(debug/createdump)
- endif()
+ if(CLR_CMAKE_PLATFORM_LINUX AND NOT CLR_CMAKE_PLATFORM_UNIX_X86)
+ add_subdirectory(debug/createdump)
endif(CLR_CMAKE_PLATFORM_LINUX)
add_subdirectory(ToolBox/SOS/Strike)