summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorPat Gavlin <pagavlin@microsoft.com>2016-04-14 12:57:41 -0700
committerPat Gavlin <pagavlin@microsoft.com>2016-04-14 15:21:29 -0700
commita3bb6a066eae8a7daede52ed576e8cd8d1d50780 (patch)
tree03ac73ed2dc362c487baaa2705ab864d833f0435 /src/CMakeLists.txt
parente63de4a0d1dd9c5ad840495579c5437a0095bea1 (diff)
downloadcoreclr-a3bb6a066eae8a7daede52ed576e8cd8d1d50780.tar.gz
coreclr-a3bb6a066eae8a7daede52ed576e8cd8d1d50780.tar.bz2
coreclr-a3bb6a066eae8a7daede52ed576e8cd8d1d50780.zip
Make it possible to build JIT32 in the OSS tree.
This change adds a new argument to build.cmd, buildjit32, that configures the build to build and link JIT32 instead of RyuJIT if the sources are available in `src/jit32`.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4ae4a7c808..957be0ef38 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -127,6 +127,11 @@ add_subdirectory(utilcode)
add_subdirectory(gcinfo)
add_subdirectory(coreclr)
add_subdirectory(jit)
+
+if(IS_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/jit32")
+ add_subdirectory(jit32)
+endif()
+
add_subdirectory(vm)
add_subdirectory(md)
add_subdirectory(debug)