summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2015-08-13 18:36:31 -0700
committerMike McLaughlin <mikem@microsoft.com>2015-08-22 00:59:18 -0700
commit2f4462661a5134428738c0da4ef2061857b7528e (patch)
treeb6d3ae2908b396a3ace295c3b5686ed9696e9cc9 /src/CMakeLists.txt
parent6bad4f89818630e9ccc12b4c7f5b4838e8982ec3 (diff)
downloadcoreclr-2f4462661a5134428738c0da4ef2061857b7528e.tar.gz
coreclr-2f4462661a5134428738c0da4ef2061857b7528e.tar.bz2
coreclr-2f4462661a5134428738c0da4ef2061857b7528e.zip
Enable gcroot and other gc related sos commands.
The "gcroot" command currently doesn't work with lldb 3.6 (our default package), but works fine with lldb 3.7.0. lldb 3.6 terminates with (lldb) sos GCRoot 00007fffcc004ce8 *** Error in `lldb-3.6': munmap_chunk(): invalid pointer: 0x000000000184cde8 *** PAL_STDCPP_COMPAT is the define that the VS team added to allow the xplat headers to be used. This is neccessary for the whole SOS directory now because gcroot and other gc commands need unorderd_map, unorderd_set, etc. from the stdlib. Had to change all wchar_t to WCHAR because the xplat stdlib default is UTF32. Had to rename and provide macros that conflict with the stdlib: wcslen -> _wcslen wcsncmp -> _wcsncmp wcsrchr -> _wcsrchr wcscmp -> _wcscmp wcschr -> _wcschr wcscspn -> _wcscspn wcscat -> _wcscat __in -> ___in __out -> ___out max(a, b) -> _max(a, b) min(a, b) -> _min(a, b) Had to ifdef PAL_STDCPP_COMPAT a lot more of pal.h, palrt.h and some other header files. Changed a bunch of L"" to W("").
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4520b9307c..ded1a95bbc 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -22,6 +22,11 @@ include_directories("classlibnative/cryptography")
include_directories("classlibnative/inc")
if(CLR_CMAKE_PLATFORM_UNIX)
+ add_subdirectory(ToolBox/SOS/Strike)
+
+ # Include the dummy c++ include files
+ include_directories("pal/inc/rt/cpp")
+
# This prevents inclusion of standard C compiler headers
add_compile_options(-nostdinc)
@@ -29,7 +34,6 @@ if(CLR_CMAKE_PLATFORM_UNIX)
# This prevents inclusion of standard C++ compiler headers
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -nostdinc++")
endif(NOT CLR_CMAKE_PLATFORM_DARWIN)
-
endif(CLR_CMAKE_PLATFORM_UNIX)
add_subdirectory(utilcode)