summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Vorlicek <janvorli@microsoft.com>2015-02-20 13:36:45 +0100
committerJan Vorlicek <janvorli@microsoft.com>2015-02-20 13:36:45 +0100
commit8eb59dba9ed6e7a46747bc0b3e75cc720dd536f0 (patch)
treeb1ac89bdc919eadfd6101c4a4dd9b6a55c917ffd /src/CMakeLists.txt
parent01f17306432715a66a7a18e9370723670886097d (diff)
downloadcoreclr-8eb59dba9ed6e7a46747bc0b3e75cc720dd536f0.tar.gz
coreclr-8eb59dba9ed6e7a46747bc0b3e75cc720dd536f0.tar.bz2
coreclr-8eb59dba9ed6e7a46747bc0b3e75cc720dd536f0.zip
Reimplement native exception handling for PAL
This change removes the preexisting exception handling in PAL that was simulating Windows SEH using a lot of low level machinery. The only remaining part is the code that raises the exception and that extracts the exception context information. The PAL_TRY, PAL_EXCEPT, PAL_FINALLY, ... macros are reimplemented using plain C++ exception handling.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt19
1 files changed, 8 insertions, 11 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6401672e54..439464146a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -10,19 +10,16 @@ include_directories("classlibnative/bcltype")
include_directories("classlibnative/cryptography")
include_directories("classlibnative/inc")
-if(WIN32)
-enable_language(ASM_MASM)
-else()
-enable_language(ASM)
-# This prevents inclusion of standard C compiler headers
-add_compile_options(-nostdinc)
+if(CLR_CMAKE_PLATFORM_UNIX)
+ # This prevents inclusion of standard C compiler headers
+ add_compile_options(-nostdinc)
-if(NOT CLR_CMAKE_PLATFORM_DARWIN)
- # This prevents inclusion of standard C++ compiler headers
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -nostdinc++")
-endif(NOT CLR_CMAKE_PLATFORM_DARWIN)
+ if(NOT CLR_CMAKE_PLATFORM_DARWIN)
+ # This prevents inclusion of standard C++ compiler headers
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -nostdinc++")
+ endif(NOT CLR_CMAKE_PLATFORM_DARWIN)
-endif(WIN32)
+endif(CLR_CMAKE_PLATFORM_UNIX)
add_subdirectory(utilcode)
add_subdirectory(gcinfo)